Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Invalid SD Card after 1.5 Firmware Update?

Discussion in 'Phantom 3 Help' started by Andrew Allsbury, Nov 28, 2015.

  1. Andrew Allsbury

    Joined:
    Nov 21, 2015
    Messages:
    35
    Likes Received:
    5
    Soooo...I updated to the latest firmware on both my p3p and my rc controllers. All seemed well except when I put in my fairly new 32gb SanDisk Extree HC I 3 Class 10 micro sd card. When I put it in, it worked fine. Recorded fine. Then I shut down the drone to change batteries, powered back up and got a prolonged initiating sd card message, followed by invalid sd card. Popped the card out and then back in, worked fine. But every time I shut down for a battery swap I now have to pop the card in and out, this is not right. Doesnt seem to be doing it with any other cards... any thoughts?

    I am going to try formatting it with the tool off of SDcard.org, but besides that I am out of ideas.

    Again, this card worked FINE prior to the last firmware update.
     
  2. snerd

    Joined:
    May 5, 2015
    Messages:
    2,633
    Likes Received:
    1,585
    Location:
    Oklahoma
    Have you tried formatting it in the bird with the Go app?
     
  3. Andrew Allsbury

    Joined:
    Nov 21, 2015
    Messages:
    35
    Likes Received:
    5
    Yes I tried formatting in p3p. Still no change. Coincidentally I believe the card it doesn't like was the card I used to load the firmware.
     
  4. snerd

    Joined:
    May 5, 2015
    Messages:
    2,633
    Likes Received:
    1,585
    Location:
    Oklahoma
    I don't guess I've ever had a card go bad on me, so don't know what to tell you. But I'd keep an eye on that one. You have other cards to use that don't get the error?
     
  5. Andrew Allsbury

    Joined:
    Nov 21, 2015
    Messages:
    35
    Likes Received:
    5
    Yes I have a few other cards that seem to be operating without issue. However I do believe this is some kind of firmware bug. I will investigate further and report back.
     
  6. snerd

    Joined:
    May 5, 2015
    Messages:
    2,633
    Likes Received:
    1,585
    Location:
    Oklahoma
    If it was a firmware bug, it would do it on the other cards as well. Sounds like a bad card to me.
     
  7. Andrew Allsbury

    Joined:
    Nov 21, 2015
    Messages:
    35
    Likes Received:
    5
    Formatting did not work using the sdcard.org app. Again, card works fine, but must be popped out and popped back in every time the bird is restarted. Card also works fine in all other devices. It would be a pretty serious coincidence for the SD card to "just happen" to have this weird form of failure right after the firmware update.
     
  8. Meta4

    Meta4 Moderator
    Staff Member

    Joined:
    Jan 8, 2014
    Messages:
    7,737
    Likes Received:
    3,451
    Not such a serious coincidence that anyone else has reported it though??
     
  9. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    It may be causing the cracked shells-- :Dcouldn't resist that one
     
  10. Andrew Allsbury

    Joined:
    Nov 21, 2015
    Messages:
    35
    Likes Received:
    5
    Just for an update, I replaced the card with the same 32gb brand, same issue, still didn't work. Replaced the bird, card worked fine. It was a firmware bug with that specific P3P.
     
  11. lenmcgilvary

    Joined:
    Dec 8, 2015
    Messages:
    99
    Likes Received:
    19
    Location:
    Calgary Canada
    I don't have this problem, but on another device I needed a u3 card because of write speed