Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Standard Intelligent flight modes

Discussion in 'Phantom 3 Help' started by Gazza999, Apr 3, 2016.

  1. Gazza999

    Joined:
    Apr 3, 2016
    Messages:
    5
    Likes Received:
    0
    Hi


    I bought a Phantom 3 Standard yesterday and I have been messing around on the simulator rather than crash it into a tree on the first flight J


    I have an issue with getting the Intelligent flight modes to work.


    After taking off and selecting F-mode, the selections appear as expected. I select one (Course lock, for example), and apply and a message appears on screen with a green tick saying "Enter Course lock mode. Exit F-Mode to exit intelligent navigation" (Pic attached)


    From that, I would assume that this mode is now active, but it is not. The same applies to POI and the others.


    After looking at some videos on youtube, this seems to be the correct procedure, but it doesn't appear to work.


    Am I missing something here ?


    Thanks
     

    Attached Files:

  2. mdowney58

    Joined:
    Feb 15, 2016
    Messages:
    492
    Likes Received:
    117
    Location:
    Mountain City, TN
    While I've only used the simulator one time, and did not use F Mode, what you are describing, and showing in the picture are accurate to how it works in flight.
    To avoid confusion, Course Lock mode may be hard to see results on the simulator.
    I'll try it in a few and report back here.

    Sent from my SM-N910V using Tapatalk
     
  3. mdowney58

    Joined:
    Feb 15, 2016
    Messages:
    492
    Likes Received:
    117
    Location:
    Mountain City, TN
    Ok, just experimented with the simulator, and Course Lock & Home Lock perform in the simulator just as they do in real life.
    Are you sure that you understand what those modes do?

    Sent from my SM-N910V using Tapatalk
     
  4. Gazza999

    Joined:
    Apr 3, 2016
    Messages:
    5
    Likes Received:
    0
    Yeah, I think I know how it works.

    Here is what's happening in the simulator:

    I take off and fly forward a few feet.
    Right stick forward= aircraft flies forward away from me
    Right stick back=aircraft flies backwards towards me

    I turn on Course lock.

    I spin the aircraft 90 degrees
    I believe that what should happen is that the controls stay as they were above:
    Right stick forward= aircraft flies forward away from me (from my perspective)
    Right stick back=aircraft flies backwards towards me (from my perspective)

    But what is actually happening is
    Right stick forward= aircraft flies to my left
    Right stick back=aircraft flies to my right

    So, even though it appears to be set, it does not actually apply these settings.



    I also tried the POI:

    I hovered at 20m and set that as POI.
    I flew away and set the speed for a 1 min circle and hit apply
    Then confirmed the return home altitude

    At this point it should start to fly a circle, but it just hovered there not moving.


    I'll take the aircraft out tomorrow when it stops raining, I'm just concerned that things are not working as they should because the simulator seems to work fine with these functions in various youtube videos.

    Hopefully, I'm just missing something bleeding obvious, but any thoughts would be appreciated.



    Cheers


    EDIT: Strangely, the waypoint mode works fine.
     
    #4 Gazza999, Apr 3, 2016
    Last edited: Apr 3, 2016
  5. mdowney58

    Joined:
    Feb 15, 2016
    Messages:
    492
    Likes Received:
    117
    Location:
    Mountain City, TN
    Yes, it sounds like you have the correct understanding.

    Sent from my SM-N910V using Tapatalk