Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Intelligent flight modes menu does not work.

Discussion in 'Phantom 3 Help' started by Doug Wilson, Mar 19, 2016.

  1. Doug Wilson

    Joined:
    Mar 12, 2016
    Messages:
    2
    Likes Received:
    0
    Location:
    Cottonwood Heights, UT
    At 65 feet + cannot get Intelligent flight mode menu to come up. Am I doing something wrong?
     
  2. garykeithmead1

    Joined:
    Nov 29, 2015
    Messages:
    259
    Likes Received:
    39
    Location:
    Uk
    Enable Intelligent flight mode in the app settings. (Under Main Control settings).
     
  3. DrJoe

    Joined:
    Apr 13, 2014
    Messages:
    591
    Likes Received:
    96
    One of a few things, first in app settings.
    Make sure you are not in beginner mode.
    Enable intelligent flight mode.
    Note the switch is greyed out in the app, that's ok... it was disabled in favor of the switch on the controller.
    On the controller, move the left switch on top to "F". This will bring up IFM on you screen.
     
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,096
    Likes Received:
    5,623
    Location:
    US
    Which version of the firmware do you have installed? You'll need 1.4 (or higher) in order to use those features.