Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Installing DJI-Vision app on Android 4.4

Discussion in 'FPV (First Person View)' started by TravlnMark, Sep 16, 2014.

  1. TravlnMark

    Joined:
    Sep 16, 2014
    Messages:
    3
    Likes Received:
    0
    I recently purchased a Phantom 2 Vision + and have been flying it using an iPhone 5 for the FPV. But the screen seems a bit small so I purchased a small tablet at Best Buy hoping to use it in place of the iPhone 5. But when I attempt to download the DJI-Vision app to the tablet, I get a message stating, “Your devise isn’t compatible with this version.” The tablet I purchased is a DigiLand DL700D. It also sais “Android 4.4” on the box.

    Has anyone else had this issue and if so, were you successful downloading the DJI-Vision app to your tablet?

    Any tips would be greatly appreciated.

    Thanks,
    Mark
     
  2. skippkon

    Joined:
    Aug 18, 2014
    Messages:
    13
    Likes Received:
    1
    HI
    I just went through that with a phone. on that same page on the google app site there should be a link where you can get it. It's down in the info about the app.If that doesn't work search youtub for a video on how to download apps to your computer. Then you can transfer to the tab and hopefully install it .
    skippkon
     
  3. tonylumps

    Joined:
    Jul 30, 2014
    Messages:
    81
    Likes Received:
    4
    Location:
    Newtown Square Pa