Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Installed new ribbon but camera doesn't work

Discussion in 'Standard/4k Discussion' started by Ghost Rider, Apr 29, 2016.

  1. Ghost Rider

    Joined:
    Apr 5, 2016
    Messages:
    319
    Likes Received:
    88
    I installed a new ribbon and power everything up and dowloaded the firmware update but it says, no SD card. Well the SD card is in the camera. The gimble doesn't move at all on power up and I can't get it to work after the gimble repair. The camera is warm and you can hear each motor hum when you touch the gimble and turn it. It sounds like everything is fine but nothing moves.
     
  2. Zeprider

    Joined:
    Mar 13, 2016
    Messages:
    200
    Likes Received:
    71
    Location:
    Hollywood, Florida
    Wish I could provide a helpful answer but I can tell you from what I have read, that ribbon cable is a PITA and if done wrong will not prove positive.

    Even the pros have trouble with that cable.
     
  3. Ghost Rider

    Joined:
    Apr 5, 2016
    Messages:
    319
    Likes Received:
    88
    I'll try one more cable. Then I'm gonna just sell it as is.
     
  4. Mr. Pina Colada

    Joined:
    Apr 15, 2016
    Messages:
    50
    Likes Received:
    13
    Try formatting the SD card and then redownloading the software
     
  5. Ghost Rider

    Joined:
    Apr 5, 2016
    Messages:
    319
    Likes Received:
    88
    I reformatted a few cards. I even hook the aircraft up to the computer to find the card. No dice.
     
  6. Squirrel!

    Joined:
    Mar 2, 2016
    Messages:
    854
    Likes Received:
    277
    How much are you asking for it?
     
  7. Ghost Rider

    Joined:
    Apr 5, 2016
    Messages:
    319
    Likes Received:
    88
    I'll put it on eBay and let it go auction.
     
  8. Squirrel!

    Joined:
    Mar 2, 2016
    Messages:
    854
    Likes Received:
    277
  9. Ghost Rider

    Joined:
    Apr 5, 2016
    Messages:
    319
    Likes Received:
    88
    I'm gonna try one more cable first.
     
Loading...
Similar Threads - Installed ribbon camera Forum Date
Installed new ribbon, but camera not moving p3a General Discussion Jul 10, 2016
Installed gimbal ribbon protector ??? Pro/Adv Discussion Jan 31, 2016
SOLD!!! GL300A with Itelite DBS02 Range Extender Installed Perfect Condition Tested Classifieds Jun 6, 2017
Installed these today for mine and my sons p3s's Standard/4k Discussion Apr 19, 2017
P3 Controllers with HDMI modules installed Classifieds Apr 12, 2017