Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Advanced IMU Calibration Problem

Discussion in 'Phantom 3 Help' started by Arturo Grez, Apr 18, 2016.

  1. Arturo Grez

    Joined:
    Apr 18, 2016
    Messages:
    2
    Likes Received:
    0
    I just updated the RC of my P3A, and the following problems raised:

    -Even though the Camera view is working, the aircraft don't respond to the RC instructions. It doesn't turn on the aircraft, and the gimbal doesn't pan, I cannot change the exposure, basically I cant do anything, apart of seeing the live view.

    -In the "status" I get always Aircraft warming, and this can stay for long periods of time (more than 15 min).

    - When I display the status menu, it show an error that indicates the IMU isn't calibrated (image). But when I try to calibrate it won't calibrate. It doesn't show any number in the sensor(image), and the calibration get stuck at 0%.

    Before this the phantom was working perfectly, please help me. Any suggestion is welcome.

    Screenshot_20160418-193207.png Screenshot_20160418-192737.png
     
  2. With The Birds

    Joined:
    Jan 4, 2016
    Messages:
    2,614
    Likes Received:
    745
    Location:
    Australia
    Have you updated the aircraft firmware? This is one update round where you need both updated for things to work.
     
  3. Arturo Grez

    Joined:
    Apr 18, 2016
    Messages:
    2
    Likes Received:
    0
    I did, and it solved my problem. For the rest of the people, if you only update the RC, and don't update the aircraft, then you are going to have the same that I did.

    Thnxs With the Birds!!