Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

I'm on FW 1.08 and I don't plan to upgrade. Mistake?

Discussion in 'General Discussion' started by witold, Nov 6, 2014.

  1. witold

    Joined:
    Jun 26, 2014
    Messages:
    493
    Likes Received:
    104
    I'm using a 3rd party gimbal and with every firmware release I'm looking for a reason to upgrade but I'm just not seeing it. It seems like more restrictions and more limitations and not much else.

    Do you guys think this is a mistake?
     
  2. 750r

    Joined:
    Nov 27, 2013
    Messages:
    1,217
    Likes Received:
    409
    Location:
    Pa, USA
    I have no problems on 1.8 . I did go up to 2.0 when it came out then went back to 1.8 where she's staying :D
     
  3. hotstink626

    Joined:
    Dec 7, 2013
    Messages:
    143
    Likes Received:
    1
    1.8 for me had over 50 flights on that no problems knock on wood :)
     
  4. DrD

    DrD

    Joined:
    Aug 19, 2014
    Messages:
    107
    Likes Received:
    0
    You don't need to use the updates. Things will remain as they were. By the way, is your Edsel still running ok?
     
Loading...
Similar Threads - I'm don't plan Forum Date
New Canada drone laws very restrictive! I'm glad I don't live there!! Rules and Regulations Mar 16, 2017
Please don't laugh. Well I guess you can but I'm kinda bummed Phantom 3 Help Jun 30, 2015
I'm stuck and simply don't know which P2 FPV system to pick FPV (First Person View) Jun 21, 2014
I want goggles but I'm pretty much broke... FPV (First Person View) Jun 12, 2017
Sharing one of the flying techniques i'm learning General Discussion Jun 10, 2017