Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

I'm at my wits end

Discussion in 'General Discussion' started by low&slow, Feb 5, 2015.

  1. low&slow

    Joined:
    Jan 9, 2015
    Messages:
    46
    Likes Received:
    2
    For the last two days I have been trying to get the blades out of my video. All I want to do is angle the camera down a little. I just can't figure it out. Nothing I do works.


    Settings on phantom RC
    [​IMG]


    Setting on Tarot gimbal
    [​IMG]
    Any help would be greatly appreciated.
     
  2. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,105
    Likes Received:
    404
    Location:
    Commerce Twp,MI
    Why not change the lens setting on your gph4b from wide angle to either medium or narrow.
     
  3. IflyinWY

    Joined:
    Sep 12, 2014
    Messages:
    3,470
    Likes Received:
    939
    Location:
    Where the deer and the antelope play
    I'm not familiar with that gimbal but my cheap Chinese gimbal needed to have a separate connection to Naza to control the pitch. Is yours just powered or connected to the Naza as well?
     
  4. low&slow

    Joined:
    Jan 9, 2015
    Messages:
    46
    Likes Received:
    2
    That will have to be the solution for now. I like the view you get with a little bit of downward tilt. So I want to figure it out.

    IflyinWY, I connected to the F2 on the Naza. I followed these steps http://www.riot.ch/tarot-t-2d-gimbal-co ... i-phantom/
    The gimbal works well, I really like the way it works. I just cant get it to tilt. I have Init Tilt Angle set at -20. I think it ignores it because the phantom RC is in control. Not sure of that tho.
     
  5. CarlJ

    Joined:
    Feb 24, 2014
    Messages:
    782
    Likes Received:
    19
    Location:
    Peru, Indiana
    no, No, NO!

    This will never do...we simply do not have enough information. Please confirm that you have followed each of these steps:

    #1) Wiring

    viewtopic.php?f=19&t=12421&start=10

    #2) Firmware

    You must update the firmware for both the control board AND the motors, you may not update one and not the other, BOTH must be updated.

    #3) Calibrate X1 in your asst software

    [​IMG]
     
  6. CarlJ

    Joined:
    Feb 24, 2014
    Messages:
    782
    Likes Received:
    19
    Location:
    Peru, Indiana
  7. low&slow

    Joined:
    Jan 9, 2015
    Messages:
    46
    Likes Received:
    2
    1. Wiring is correct.

    2. When I go to update the firmware I get this. But I do have V1.5 on both the control board and motors. It says V1.5 on both.
    [​IMG]

    3.Done.

    I don't have the default mode stick position option on my screen. I appreciate the help Carl.
     
  8. CarlJ

    Joined:
    Feb 24, 2014
    Messages:
    782
    Likes Received:
    19
    Location:
    Peru, Indiana
    Are you able to open a com port and connect?

    Oh, and the software lies, you don't really know what you have until you've connected.
     
  9. CarlJ

    Joined:
    Feb 24, 2014
    Messages:
    782
    Likes Received:
    19
    Location:
    Peru, Indiana
  10. CarlJ

    Joined:
    Feb 24, 2014
    Messages:
    782
    Likes Received:
    19
    Location:
    Peru, Indiana
  11. low&slow

    Joined:
    Jan 9, 2015
    Messages:
    46
    Likes Received:
    2
    When I click on the link on the Tarot site I get this.

    [​IMG]

    I did get the software from another site, and updated the firmware. I got the green progress bar on the main controller, and yellow progress bar on the motor controller. It said I updated successfully. I still don't have the same screen that you have. I don't have the mode stick position on my screen. I can enter angle limits and that works. Init Tilt Angle does not work. I can't click on mode1 or mode2 either. I'm losing my mind.
     
  12. low&slow

    Joined:
    Jan 9, 2015
    Messages:
    46
    Likes Received:
    2
    OK, I have the right software.


    [​IMG]

    I set it up identical to your picture. Steps #1 #2 and #3 are complete. What's next?
     
  13. CarlJ

    Joined:
    Feb 24, 2014
    Messages:
    782
    Likes Received:
    19
    Location:
    Peru, Indiana
    I believe I have my motors reversed, pretty sure I do. but your tilt should be working now.

    I assume you were able to follow along with the youtube video and update the firmware for motors and control board?

    Home page for Tarot just in case: http://www.tarot-rc.com/
     
  14. low&slow

    Joined:
    Jan 9, 2015
    Messages:
    46
    Likes Received:
    2
    It will not let me enter tilt angle. I get ?????. All the other boxes work, but not tilt angle or RC monitor. Maybe I'm stuck without tilt.

    [​IMG]
     
  15. CarlJ

    Joined:
    Feb 24, 2014
    Messages:
    782
    Likes Received:
    19
    Location:
    Peru, Indiana
    There's no crying in gimbals!?! Wha...there's no crying! :cry:

    Ok, it's time to put on our big girl panties, and do this!

    It appears you're not connecting to the gimbal control board. If you follow the directions in the youtube video you know how to open the com port (short for communications port). The thing is...the computer may be using a port or it may be sharing the port you have the software set on. Let's ensure that you're using the right com port.

    Use the provided USB dongle to connect the Gimbal board to your computer (Windows only). If this is the first time you have plugged in the dongle you will likely see a USB device installation window. After successful installation of the driver a new COM port named “Prolific USB-to-Serial Comm Port” should appear in the Device Manager as shown below. If drivers cannot be found you may be able to install Windows 7 or Windows XP drivers using one of the .exe files found in the “driver” directory of the Tarot Gimbal Firmware v1.5 zip file

    Link to v1.5 zip (not Tarot): http://ardupilot.com/downloads/?did=110

    [​IMG]
     
  16. CarlJ

    Joined:
    Feb 24, 2014
    Messages:
    782
    Likes Received:
    19
    Location:
    Peru, Indiana
    So in summary:

    #1) Make sure you've updated your driver which can be found in the v1.5 firmware update zip (link provided above)

    #2) Follow the directions above for connecting the gimbal control board to your computer, open device manager and locate "Prolific USB-Serial Comm Port (COMyourcomhere)"

    #3) Ensure you're using the same com port as the gimbal software

    #4) By right clicking on "Prolific USB-Serial Comm Port" in the device manage you can select properties and change the com port manually. Let's hope that's not needed but if it is, use a com port of 5-11. Again ensure that the settings are the same in the gimbal software

    #5) I have a cracked Windows 8 version of the gimbal software, so the look of my software may differ

    #6) Once we've completed with your connection issue, we'll need to get back to the topic of updating the firmware for both the motors and the control board

    I'm like a broken record over here! :shock:
     
  17. low&slow

    Joined:
    Jan 9, 2015
    Messages:
    46
    Likes Received:
    2
    I removed all the software and started over with the link you provided. I did 1-6 again with no luck. So I loaded V1.4. The gimbal started to vibrate and jump around. So I put V1.5 back on it. I can change the speed in RC Sensitivity It will let me do that, but if I change the box below that (Init Tilt Angle) when I press enter I get ?????????!.
     
  18. IflyinWY

    Joined:
    Sep 12, 2014
    Messages:
    3,470
    Likes Received:
    939
    Location:
    Where the deer and the antelope play
    To start with,
    This is the best title for a thread that I've ever seen. I have nothing helpful to offer here. I'm just having fun. So if you're being serious, just pass by this addition to the thread.

    Because then you folks include this: I believe I have my motors reversed, :roll: :lol: :roll:


    At that point, I'm laughing hysterically.
    And the thread continues on...
    "Maybe I'm stuck without tilt" :lol:
    And on...
    "The gimbal started to vibrate and jump around" :lol: :lol:
    And, yes, out of context I find this:
    There's no crying in gimbals!?! Wha...there's no crying! :cry: :cry: :lol: :cry:

    I'll not quote anyone.
    I'll just basque in the warmth of the Wyoming Winter Warmth. :lol: :lol: :lol:

    Word of advice... get outside and get some fresh air.

    Your's truly,
    Laughing my freaking *** off
     
  19. CarlJ

    Joined:
    Feb 24, 2014
    Messages:
    782
    Likes Received:
    19
    Location:
    Peru, Indiana
    Yeah, it's gonna twitch until we get the software/firmware issue fixed, and it will not except any input until we get the issue fixed.

    We must have these 3 things:

    #1) The v1.5 USB Driver

    #2) The v1.5 Software (Not 1.4 or 1.3 or any other, it MUST be v1.5)

    #3) The v1.5 Firmware for the control board AND the motors

    (Edit: and just to be extra clear, all the above must match, it ALL has to be v1.5)

    Follow the directions in this video: https://www.youtube.com/watch?v=A2WXguD2Ghs

    If you are unable to complete any step in the video, please post here with that failure, and screenshots are always helpful.

    To be clear the only issue I'm interested in at this point is:

    A) All software/firmware updated to v1.5

    B) Your ability to open the com port, and upgrade the firmware as instructed in the video, make sure to follow each step in the video.

    Once that is complete I'll post directions for flashing the control board with the new tilt angle, but it simply will not work until the above is complete.
     
  20. CarlJ

    Joined:
    Feb 24, 2014
    Messages:
    782
    Likes Received:
    19
    Location:
    Peru, Indiana
    ;)