Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

I have no idea what is wrong... HELP!

Discussion in 'Phantom 1 Help' started by astralisdp, Aug 27, 2013.

  1. astralisdp

    Joined:
    Aug 27, 2013
    Messages:
    4
    Likes Received:
    0
    I have been flying Phantoms for the past 6 months or so and never had this problem before.

    Yesterday I wasn't able to calibrate the GPS for some reason. I flipped the GPS Switch up and down 10 times like normal and the LED on the back of the Phantom would just blink a steady green constantly (about every half-second) without any change. I decided to fly it anyway out of GPS and it flew just fine.

    Today I tried installing the new firmware for the first time, and now the Phantom continues to blink the steady green but will not start up at all. It's as if the control will not connect to the Phantom.

    The NAZA Assist software will also not recognize the control and I have reinstalled the driver 3 times.

    Please help! Thanks!
     
  2. will27

    Joined:
    Jul 22, 2013
    Messages:
    53
    Likes Received:
    0
    I'm having the same issue in that I can't get the compass to calibrate. I can still fly it though. I'm also using a Naza M Lite controller. I hope someone has an idea about the compass. Mine flies alright, but doesn't lock in place when you neutralize the controls like my other phantom does.
     
  3. rampage42

    Joined:
    Jul 29, 2013
    Messages:
    49
    Likes Received:
    0
    Open the Naza software and make sure PPE is selected for receiver type, not D Bus.
     
  4. astralisdp

    Joined:
    Aug 27, 2013
    Messages:
    4
    Likes Received:
    0
    Thanx rampage42,
    My buddy helped me out with exactly what you suggested, and that fixed a few problems, but my phantom still only blinks green. It does fly now though which is great, but even when the battery is about to die while flying, the LED blinks green. Never seen it before.

    Thanks!
     
  5. martcerv

    Joined:
    May 27, 2013
    Messages:
    1,002
    Likes Received:
    2
    It could be possible the red led or wiring is faulty, if you look inside your phantom through the battery door you may see some wires at the back of the battery compartment. These wires are for the LED and USB and its possible you may have crushed a wire with the battery. This could be the red led wire and if so it may have failed, does the yellow LED function still when in ATTI mode?

    I think you should take a look at the the led assembly and see if there is any possible damage to the wiring as that could cause this issue.
     
  6. rampage42

    Joined:
    Jul 29, 2013
    Messages:
    49
    Likes Received:
    0
    Glad it worked. Look in the software again and check the battery voltage warnings, you can set it up to blink at one voltage and land at the next lower voltage. Not near my computer for the correct numbers.
    Maybe someone can post them.
     
  7. astralisdp

    Joined:
    Aug 27, 2013
    Messages:
    4
    Likes Received:
    0
    Ok so the update is that I opened it up, all the wiring seems to be correct and secure but now the Green LED is constant. No blinking at all. It starts up and can fly but I don't think the GPS is working and still no other colors from the LED. I would bring it to the dealer but the dealer is Amazon. Anyone see this before? Thank you guys
     
  8. Iron Creek

    Joined:
    Aug 21, 2013
    Messages:
    23
    Likes Received:
    0
    Location:
    Tucson, AZ
    Amazon is just the middleman your receipt should say the company it was sold/shipped from.
     
  9. astralisdp

    Joined:
    Aug 27, 2013
    Messages:
    4
    Likes Received:
    0
    You're totally right but I just tried finding a way to contact the retailer but they have no available number/email. Doubt they would know what to do anyway. Going to contact DJI again now. Thanks