Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

I get NOTHING!

Discussion in 'Phantom 1 Help' started by tbokane, Jan 7, 2014.

  1. tbokane

    Joined:
    Jan 1, 2014
    Messages:
    3
    Likes Received:
    0
    A real newbie here. I bought the Phantom and had it working within short period of time. Then I went to use it again and after installing a fully charged battery I get absolutely nothing......no lights...no beeps...nothing. The battery/quad is a week old and has barely been used...maybe 5 minutes...no crashes either. I can't even turn it on to try setting it up from scratch. Any ideas would be greatly appreciated.
     
  2. Thesmokeshow

    Joined:
    Sep 18, 2013
    Messages:
    30
    Likes Received:
    0
    Do u have a battery checker? check that battery is ok and fully charged. You could use a multimeter to see what voltage its getting maybe it lost a cell?
     
  3. tbokane

    Joined:
    Jan 1, 2014
    Messages:
    3
    Likes Received:
    0
    is that something I could buy at Radio Shack? My charger is flashing green, but nothing happens when I install the battery into the Phantom. I appreciate your input.
     
  4. iResq

    Joined:
    Dec 23, 2013
    Messages:
    545
    Likes Received:
    2
    Location:
    Annapolis, Maryland
  5. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    I almost bought that one, but settled on this one instead (works great, just a bit cheaper): http://www.amazon.com/gp/product/B000EV ... UTF8&psc=1

    tbokane, if you need something that ONLY checks levels on a LiPo/LiFe battery (i.e. not a full multimeter), you can use something like this: http://www.buddyrc.com/3-in-1-battery-c ... arger.html
     
  6. tbokane

    Joined:
    Jan 1, 2014
    Messages:
    3
    Likes Received:
    0
    thanks to all...guess I will buy one of these battery testers.