Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

I get no success or fail message when i calibrate!

Discussion in 'General Discussion' started by wackoz, Jul 2, 2014.

  1. wackoz

    Joined:
    Feb 10, 2014
    Messages:
    8
    Likes Received:
    0
    Hello!

    When I try to calibrate my compass I can enter the calibration mode. The lights are solid yellow. And then when i do the first spin they get solid green. But when i rotate the copter (Nose down) and rotate it counter clockwise i get no success or failmessage to the calibration. It just goes straight back to slow yellow blinking?

    Tried everything, can't calibrate the **** copter...

    Anyone know what the problem is?

    Thankfull for answers.

    Best regards Alex!
     
  2. BMEWS

    Joined:
    Mar 25, 2014
    Messages:
    368
    Likes Received:
    0
    Location:
    Cambridgeshire UK
    what model phantom are you trying to calibrate?

    Bmews
     
  3. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    It sounds like you're completing the calibration ok but you might not be leaving the switch in the top (GPS) position when you do it, so it returns to a yellow blink for ATTI mode.

    The proper response from the Phantom when you complete the 2nd part of the calibration (nose-down) is to just switch from the solid green to the regular LED indicator for whatever flight mode it's in.
     
  4. wackoz

    Joined:
    Feb 10, 2014
    Messages:
    8
    Likes Received:
    0
    I'm doing it right. I have watched some videos on how to calibrate. I'm sure I leave it in GPS mode when done. No matter what I do I can't get the success message and the green blinking.

    Whenever i'm flying the phantom 2 drifts and do not stay in place when I release the levers on the remote.

    Because I can get to the first stage when the lights turn to solid green I do not think it is damaged?
    I have never crashed it or anything like that. I have just not been able to calibrate it correctly once since I got it...

    When I connect ut to the computer i get response from the compass... :(

    Still got no clue what to do :/
     
  5. wackoz

    Joined:
    Feb 10, 2014
    Messages:
    8
    Likes Received:
    0
    I'm using a Phantom 2
     
  6. MrC

    MrC

    Joined:
    Mar 11, 2014
    Messages:
    469
    Likes Received:
    6
    Location:
    Surrey. UK
    What do you get if you just turn it on and leave it, without calibrating? Flashing green or flashing yellow?
    Sounds like the switch isn't changing it to gps mode. Flashing yellow suggests it is in atti mode. Check the operation of the switches in the assistant software.

    If the calibration failed you would get red flashing lights.
     
  7. wackoz

    Joined:
    Feb 10, 2014
    Messages:
    8
    Likes Received:
    0
    If i trun it on and leave it, it blinks slow yellow!

    May be like that, but I wouldn't be able to enter calibration mode if I couldn't move the switch to GPS mode in the first place?
     
  8. MrC

    MrC

    Joined:
    Mar 11, 2014
    Messages:
    469
    Likes Received:
    6
    Location:
    Surrey. UK
    Slow yellow blink is Atti, slow green blink is GPS. Go look at the switch in the assistants and check it is working ok, maybe intermittent. Also i think you can trigger compass calibration going from atti (middle) to down and back as well as from top to bottom - not 100% on this but if so would explain how you managed to start the calibration.

    Your original compass calibration worked. When it was done it went back to normal flashing lights from the solid green. It's just it thinks it's in atti mode.