Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

How to link P3P to Litchi

Discussion in 'Pro/Adv Discussion' started by waters212, Apr 9, 2016.

  1. waters212

    Joined:
    Apr 9, 2016
    Messages:
    1
    Likes Received:
    0
    I am using a Samsung Tab S2 and/or a Samsung Galaxy S6 Edge plus.

    When I first open the Litchi app I get its main screen with the red DISCONNECTED at the top.

    How do I link it to my P3P?
     
  2. Bos123

    Joined:
    Apr 9, 2016
    Messages:
    3
    Likes Received:
    0
    You have to disable the Dji Go app otherwise litchi won't work from my experience. Because android has you set a default app to open when the RC is connected the video goes to DJI Go unless it's disabled.
     
  3. feethea

    Joined:
    Jul 31, 2015
    Messages:
    43
    Likes Received:
    9
    Several people have expressed their methods re this issue - and it is an issue. Bos123 is correct but on my Samsung S2 and Nexus 7 I follow this procedure - start tablet, start P3P, start RC and let in initialise for a few seconds then start Litchi. Works for me!
     
  4. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,124
    Likes Received:
    1,653
    Location:
    San Francisco, CA
    Are you able to connect with DJI go App?

    If yes then,

    1. Stop the DJI Go App, RC and P3 completely

    2. Switch on RC

    3. Start Litchi App

    4. Switch on P3