Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Helps, problems with DJI app after upgrading android 6!

Discussion in 'Pro/Adv Discussion' started by jason6666, Jun 6, 2016.

  1. jason6666

    Joined:
    Dec 9, 2015
    Messages:
    4
    Likes Received:
    0
    Hi

    After updating my phone (galaxy S5) to android 6 i cannot connect to my P3P with the DJIgo app.
    The camera button does not appear.

    When i connect the phone to the RC i get an option to elect for the USB.
    I have already tried all options (MTP, midi, etc) setting but the camera button does not appear.

    If i use an other phone with android 5, then everything works.

    What setting do i miss in my Android 6 phone?
    I have already tried to uninstall and install the DJI app again, but not working :(
     
  2. jason6666

    Joined:
    Dec 9, 2015
    Messages:
    4
    Likes Received:
    0
  3. Avocet

    Joined:
    Apr 3, 2016
    Messages:
    141
    Likes Received:
    36
    Well, I'm confused by your question. Perhaps some others are also. You have a galaxy s5, but what is Android 6? Your phone has an android version number or a nickname (Marshmellow or KitKat, etc.) ...

    What is your DJI Go App version? Others have suggested reinstalling DJI Go ... Hard to help out with so little information.
     
  4. jason6666

    Joined:
    Dec 9, 2015
    Messages:
    4
    Likes Received:
    0
    Oh sorry for the confusion, i have a samsung galaxy s5 and now with latest opertating software of android 6.0.1.
     
  5. Fly Dawg

    Joined:
    Apr 29, 2016
    Messages:
    119
    Likes Received:
    42
    Location:
    Watkinsville, Georgia
    Same issue here Jason. Marshmallow 6.0.1 Galaxy s5. Does not connect. Neither does Litchi.
    P3A
    AC: 1.8.80
    RC: 1.6
    APP: 2.8.1

    The above worked fine with Lollipop 5.1.1
     
  6. jason6666

    Joined:
    Dec 9, 2015
    Messages:
    4
    Likes Received:
    0
    Hi,

    Android 6.0.1 is ideed called Marshmallow.
    But i can also not connect to the drone.
    No solution?
     
  7. Avocet

    Joined:
    Apr 3, 2016
    Messages:
    141
    Likes Received:
    36
    Galaxy S7 Edge, Verizon variant running Marshmellow (6.0.1) connects fine with a brand new P3P. I used it to upgrade the firmware on a new controller. Upgraded the AC firmware with a 2gb SD Class 10 card. All is well it seems, but weather precludes anything but sim time and connectivity checks. Everything "all in the green" as the cliche goes.

    I would check firmware versions (for both the bird and the TX) and do a wipe of DJI Go app from the phone and a fresh reinstall of same.
     
  8. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,418
    Likes Received:
    568
    Location:
    Sydney Australia
    Try removing Litchi and GO.
    Then installing just GO and test.
    I read some where here that GO and Litchi installed on the same device doesn't work properly on Marshmallow.
     
  9. Digdat0

    Joined:
    Feb 20, 2016
    Messages:
    885
    Likes Received:
    393
    Location:
    Oregon, USA
    It doesn't sound like the app is installed properly. It should ask you what app to use, not how to connect. Have you tried resetting the app defaults?

    If no go, I'd open the android using file explorer and just remove all references to Dji on the system manually, redownload the app and reinstall. It's something screwed up in the Dji go app for sure.
     
  10. Fly Dawg

    Joined:
    Apr 29, 2016
    Messages:
    119
    Likes Received:
    42
    Location:
    Watkinsville, Georgia
    Jason, Give this a try. It worked for me, but only for the GO APP. There is, as another mentioned apparently
    an issue with Go and Litchi on the same device ( Bummer). Anyway, follow these steps:

    1) Uninstall Go App.
    2) Uninstall Litchi ( If applicable)
    3) Reboot Phone by pressing the Volume Up Key, The Home Key and the Power Key simoultaneously.
    From the drop down menu that appears, select Restart.( Note: When you do this, make sure your phone
    screen has timed out and is blank. It will not work otherwise.)
    4) Reinstall Go app.
    5) Connect usb cable to phone only.( Wait to connect the cable to RC)
    6) Power RC
    7) Power up AC ( Ensure the RC is Connected to AC, green light on RC)
    8) Connect USB to RC
    9) Phone should recognize and give option to set GO as default
    10) Set Go as default and you should be good from there, worked for me.

    I did not change any other settings, just as an additional note. Let me know if it works for you.
     
    DanieOos likes this.
  11. redog

    Joined:
    Jun 26, 2015
    Messages:
    4
    Likes Received:
    0
    Location:
    italy
    The same problem tablet samsumg A and samsumg s5 whit android 6.0.1 before this upgrade work everthink fine whit litchi and dji go
     
  12. Fly Dawg

    Joined:
    Apr 29, 2016
    Messages:
    119
    Likes Received:
    42
    Location:
    Watkinsville, Georgia
    Best I can determine there is no fix. You cannot, have both Go and Litchi installed at the same time on a Galaxy S5.
    It appears to be device dependent, and a Samsung/Android issue with Marshmallow 6.0.1. All was fine with Lollipop.
     
  13. cgooge

    Joined:
    May 5, 2016
    Messages:
    6
    Likes Received:
    1
    I'm having the same issue..started when I added Litchi to my Android device running Marshmallow. Bummer.
     
  14. Rommel

    Joined:
    Jun 2, 2016
    Messages:
    50
    Likes Received:
    17
    Came across this thread while researching if I should update my shield to marshmallow. I have a Galaxy S5, just checked the firmware and it's 6.0.1 marshmallow. I do not have litchi installed and app runs perfectly.

    Just an FYI
     
  15. flyNfrank

    Joined:
    Feb 1, 2014
    Messages:
    4,234
    Likes Received:
    915
    Location:
    Indy, USA
    The litchi developer told a small group for now you had to go in your phone settings/app/djiGO and select Force Stop, in order to run the litchi app until there is a work around.

    If it works come back and let others know.
     
  16. Mocho

    Joined:
    Jun 16, 2016
    Messages:
    315
    Likes Received:
    64
    Location:
    Alberta, Canada
    The issue with Android 6.0.1 and the USB port is well documented.

    Many threads here and on DJI site with various fixes reported.

    I had the same issue with my Galaxy S2 tablet.
    My fix is to go into Tablet app settings and clear the default device for DJI Go and Litchi. This will need to be done each time you switch apps. If you've done that and don't get the prompt for which app to use, unplug then plugin your USB cord.
    The new Android vr. No longer has the prompt "use only once"when using the USB port hence the issue.
     
  17. kirk2579

    Joined:
    Jan 13, 2015
    Messages:
    1,350
    Likes Received:
    264
    Location:
    Girard. ohio

    anyone notice the the posts about this not connecting is ALL Samsung...
    possibly something in the Samsung custom overlay conflicting!

    FWIW
    I have 6.0 on my Moto X pure and NVidia K1 with no issues.

    good luck and have fun flying!
     
  18. Rommel

    Joined:
    Jun 2, 2016
    Messages:
    50
    Likes Received:
    17
    Thanx for the info on the nvidia. Mine is running lollypop and I'm getting tired of looking at the update prompt lol
     
  19. DanieOos

    Joined:
    Sep 23, 2016
    Messages:
    2
    Likes Received:
    0
    Your fix worked!!! Followed your 10 steps strictly and it worked!

    Had to uninstall Drone Deploy and Dji Go, Reboot and followed your sequence and it worked! Struggled the whole day could not connect with AC! Galaxy S5 with Android 6 and latest firmware ...

    Reinstalled the latest Dji Go and set it as default when prompted. Was able to connect as soon as app started!

    Ps. Have not tried to install Drone Deploy or Litchi again.

    Well done and thank you!

    Sent from my SM-G900F using PhantomPilots mobile app
     
  20. Hvlios

    Joined:
    Oct 2, 2016
    Messages:
    6
    Likes Received:
    0
    I have the same exact problem with P3 standard, i think android marshmallow doesn't support dji go. So i'm going to downgrade to 5.1.1