Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

HELP Please---Phantom V2+ Short Lived

Discussion in 'Phantom 2 Vision + Help' started by davidsoncm, May 16, 2014.

  1. davidsoncm

    Joined:
    May 16, 2014
    Messages:
    10
    Likes Received:
    0
    Well my phantom experience was short-lived. After my 3rd flight while descending it wobbled abruptly and landed in my pool of all places. :evil: (Reminds me of the time I crashed one of my R/C planes into a pond and had to hit the only floating log in the pond)
    Anyway I got it out in less than 10 seconds quickly disconnected battery and took it apart to let it dry out. After 48 hours or so of letting it dry out I reassembled it. During this time I noticed the battery LED's where not functioning properly so I did not want to reconnect a Li-po battery with water damage back to the Phantom. Ordered a new battery charged it up and figured it was time to give it another try. So with my fingers crossed I powered the battery on and the Phantom powered up to what appeared to be normal. After the power up and all the led's flashing in the initial start appeared and chimes. I thought GREAT!!! it's going to work. However shortly after turning on the power the yellow (no green LED's) LED's light up, I go into compass calibration mode easily and calibrate the compass half the time I get the "long flashing yellow LED" the other half is a "solid green" LED. In either case the motors will not start. I go into the Phantom assistant software and connect all stick motions indicate a response to my input. But I noticed the in the firmware update under GPS I have all blanks 0.0.0. and or ----- in the Loader Hardware and Firmware sections when connected to the Phantom via the software under the "UPGRADE" sections of the software. All other firmware indications within the software are normal. I took the Phantom apart again and I noticed some corrosion on the GPS board. Everything appears just fine inside cover of the Phantom and with the software.

    A couple of questions.
    1. Any suggestions on getting this thing fixed?
    2. I have not been able to find a new GPS module that is labeled Vision 2+ I have found a Vision 2 GPS module will this work? Are they the same? Will it work
    3. On the Master Controller inside there is one side that has only one connector to it I want to confirm I have reconnected to it properly the other side is full and I and I'm certain all other connections are correct. I have scoured the internet to find MC for the Phantom Vision 2+ to confirm this but have not came up with any diagrams for pictures. (For some reason I'm thinking on that side I may have not connected it to the proper slot since there were so many empty ones on that side But I'm 90% sure it is correct I just want to confirm)
    4. If it is only the GPS module that is bad shouldn't it still at least start the motors in non-gps mode?
    5. All I have ran the phantom assistant software is a Mac. Is there a preferred operating system Windows/Mac that most guys like and works better for them?
    Thanks in advance. I love the forum and love the Phantom I just don't want to have to buy a new one.
    Thanks,
    Cliff
     
  2. 904jason

    Joined:
    Oct 2, 2015
    Messages:
    19
    Likes Received:
    0
    I would dry it out with a little heat air. The GPS is the same except for the 3 advance and pro ideas glonass or something. Just dry it out get a new compass and try it again.. mc boards and esc and motors can cost
     
  3. RoyVa

    Joined:
    Apr 10, 2015
    Messages:
    2,246
    Likes Received:
    449
    Location:
    Virginia
    Motors will not start if GPS unit is reading 0.0.0.0 in firmware. That means the quad is not seeing the module or its bad. Double check the connection. If it still show 0.0.0.0 replace it. Those modules are available on ebay for around $65-75. part #11
     
  4. N017RW

    Joined:
    May 2, 2014
    Messages:
    6,236
    Likes Received:
    1,612
    Location:
    Palm Beach Co.- FL
    The post is a year and a half old!
    Hopefully it's sorted by now.
     
  5. 904jason

    Joined:
    Oct 2, 2015
    Messages:
    19
    Likes Received:
    0
    Looking around didn't notice the date in the corner there
     
  6. dirtybum

    Joined:
    Apr 14, 2015
    Messages:
    3,314
    Likes Received:
    1,790