Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Help. No video on Black Pearl from Immersion 600mw

Discussion in 'FPV (First Person View)' started by avaerials, Jun 7, 2014.

  1. avaerials

    Joined:
    Jun 7, 2014
    Messages:
    4
    Likes Received:
    0
    Can anyone help with my set up?

    I am attaching the iOSD mini and immersion rc 600mw transmitter to my phantom 2 with zenmuse and gopro via the firstpersonview.com cable that ties them all together. I also have the Black Pearl receiver monitor.

    When I plugged them all in, all im getting is a grey screen with the flight data, NO VIDEO. So it looks like the iosd mini and transmitter are working, but the video isnt making it to the monitor. I changed the Gopro and monitor settings to PAL but still nothing.

    Does anyone have an idea of what this might be or have had the same problem? Am I missing a setting? Thanks
     
  2. kydan

    Joined:
    Feb 23, 2014
    Messages:
    440
    Likes Received:
    2
    Location:
    Chattanooga, TN
    Add some pics and that will help us troubleshoot.
     
  3. avaerials

    Joined:
    Jun 7, 2014
    Messages:
    4
    Likes Received:
    0
    Here are some pictures of the set up and the screen with no video, just flight data.
     

    Attached Files:

  4. avaerials

    Joined:
    Jun 7, 2014
    Messages:
    4
    Likes Received:
    0
    All figured out. Problem with the gopro.
     
  5. hughsnews

    Joined:
    Jan 12, 2014
    Messages:
    90
    Likes Received:
    0
    What was the problem? How'd you work it out?


    Sent from my iPhone using Tapatalk