Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Help!? Controlling Phantom after Fail-Safe return?

Discussion in 'General Discussion' started by Hagz, Sep 5, 2013.

  1. Hagz

    Joined:
    Sep 5, 2013
    Messages:
    2
    Likes Received:
    0
    Hi,
    Appreciate any input on this subject. I tested my Phantom Fail-Safe 2 different times, then when it returned an hovered back near me I flip back to GPS mode but have no control over unit. How do I gain instant control after getting out of Fail-Safe?

    Thanks
     
  2. gazchap

    Joined:
    Aug 10, 2013
    Messages:
    36
    Likes Received:
    0
    I believe you have to flick from GPS mode to ATTI mode, so if you have failsafe on the third position of that switch, you need to flick to GPS mode, and then to ATTI mode.

    Make sure your throttle is 50%+ though or it will descend as soon as you regain control.
     
  3. DeweyAXD

    Joined:
    May 31, 2013
    Messages:
    818
    Likes Received:
    9
    Location:
    Oxfordshire, UK
    As with Gazchap - The way that works for me is:
    1) Fail safe mode activated (via loss of signal, TX off or switch activation)
    2) Wait till in good visual range (leaving in GPS mode is fine for this part)
    3) Flick to Atti mode.... this should hand you back control again. Check you are in control and next get low enough to check for Satelite loss red lights... if all ok (just yellows in Atti mode) flick to GPS again if you wish. My advice though is to land in Atti mode ASAP just in case.

    Last bit of advice... test it once to confirm the above but then don't try testing it anymore. Use it as an absolute last resort especially if you turn your TX off to make it kick in. With the TX off if a stronger 2.4 signal gets on the RX's frequency at the wrong time during fail safe you stand risk of losing it and none of us want that for you.
     
  4. Hagz

    Joined:
    Sep 5, 2013
    Messages:
    2
    Likes Received:
    0
    Thanks guys appreciate the help and quick response. Being a newbie it was operator error as I was flipping straight back to GPS mode.