Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Help..CHANGE in start up tones since 3.12 upgrade

Discussion in 'Phantom 2 Discussion' started by pianoflyer, Mar 15, 2015.

  1. pianoflyer

    Joined:
    Feb 25, 2015
    Messages:
    39
    Likes Received:
    1
    Flew for first time after upgrading firmware to 3.12 .everything worked fine including led light sequences (I'm in NAZA M mode )..EXCEPT instead of hearing the rising chirps followed by 4 beeps, I'm just getting the rising chirp sound (really rapid beeps) with NO beeps following...then it goes into start up lights and everything worked fine.... Is this ok?
    Thank you
     
  2. TeamYankee

    Joined:
    May 30, 2014
    Messages:
    491
    Likes Received:
    42
    Location:
    Swansea, Wales, UK
    Sounds like "Phantom" mode... not NAZA mode?
     
  3. pianoflyer

    Joined:
    Feb 25, 2015
    Messages:
    39
    Likes Received:
    1
    Checked the assistant and shows Naza mode. Besides, I am getting IOC. Tested HL and CL. I read on another thread that lack of 4 beeps ,indicates version of ESC. Possibly new firmware corrected Starr up tone error of previous firmware version. Also saw a mention of it having to do with position of throttle stick (centered or all the way down)when turning on phantom. .still curious.
     
  4. TeamYankee

    Joined:
    May 30, 2014
    Messages:
    491
    Likes Received:
    42
    Location:
    Swansea, Wales, UK
    hmm.. I just updated mine a a couple of days ago and all seems normal. 4 beeps at the end.. P2 mark 1
     
  5. wkf94025

    Joined:
    Jan 19, 2014
    Messages:
    608
    Likes Received:
    8
    Location:
    St. Helena, CA
    I received my latest P2 a week ago, and it also lacks the 4 beeps at the end. It's not on v3.12, and ESC's are 2.1. Guessing it's the ESC's. Curious, but not concerned.

    Kelly
     
  6. N017RW

    Joined:
    May 2, 2014
    Messages:
    6,250
    Likes Received:
    1,614
    Location:
    Palm Beach Co.- FL
    I think you've got it here.

    Thought I'd read this earlier and/or elsewhaere.

    Your response deserves a: +1.
     
  7. Hughie

    Joined:
    Nov 22, 2014
    Messages:
    1,477
    Likes Received:
    141
    Location:
    Leeds, United Kingdom
    This tone seemed to lose the 4 beeps with the introduction of the v2.0 ESCs
     
  8. pianoflyer

    Joined:
    Feb 25, 2015
    Messages:
    39
    Likes Received:
    1
    What's a bit strange is that I did nothing to change the hardware of my ESC and have only had the phantom 2 for 1 month. I was getting the 4 beeps until upgrading the firmware to 3.12. So did that upgrade also upgrade the software /firmware of the ESCS so that I'm no longer getting the 4 beeps and am I safe to assume that the hardware and software of the ESCs are in sync and nothing is going to cause a malfunction. Thnx
     
  9. CityZen

    Joined:
    Oct 22, 2014
    Messages:
    940
    Likes Received:
    36
    Location:
    NYC
    The startup sounds are wholly done by the ESCs. The Phantom (NAZA) firmware has nothing to do with it.

    The older ESC firmware had the 4 extra beeps. The V2.0 and 2.1 ESC firmware do not have the 4 extra beeps.

    You cannot change the ESC firmware via the Assistant software. It requires a special rig to reprogram the ESCs.
     
  10. pianoflyer

    Joined:
    Feb 25, 2015
    Messages:
    39
    Likes Received:
    1
    Thnx , I really appreciate your input, but then I'm even more confused. Why would I have the 4 beeps for my first 5 flights and now they are gone & most importantly is it safe as I assume it's a good thing that the ESC tones are reporting the most recent software, hence no more beeps.