Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Help! Can not install DJI-vision on my phone.

Discussion in 'Phantom 2 Vision + Discussion' started by Aovelto, Jul 4, 2014.

  1. Aovelto

    Joined:
    Jul 4, 2014
    Messages:
    8
    Likes Received:
    0
    I have an HTC Desire HD.

    It does not show up in app store. When I download it through the browser it goes well until I'm opening the file. When I tap "Open" I get two options. Option 1 is "Confirm and install", with a google logo. Option 2 is "Package installation" with the android logo. It doesn't matter which one I choose. As soon as I continue it says there was a problem opening the package.

    Is there anything I can do to get the app to work on my phone?
     
  2. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,410
    Likes Received:
    567
    Location:
    Sydney Australia
  3. Aovelto

    Joined:
    Jul 4, 2014
    Messages:
    8
    Likes Received:
    0
    I get the same error as I described above.
     
  4. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    9
    Location:
    Glen Burnie, MD - USA
    I don't understand why it isn't showing up in the Google App Store. You are actually on the Google Store directly? In the search field you are typing "DJI Vision"?

    Try going to All Programs > Downloads, and delete the APK if its there and download a fresh copy. Perhaps it is corrupt?
     
  5. wattsn

    Joined:
    Jun 18, 2014
    Messages:
    190
    Likes Received:
    0
    The Desire HD is an old phone and I guess on an old version of Android. I guess the DJI app is not backwards compatible with old versions.


    Sent from my iPad using Tapatalk
     
  6. Aovelto

    Joined:
    Jul 4, 2014
    Messages:
    8
    Likes Received:
    0
    Ah, what I meant was that it does not show up in "Play store". But when I go to the website I find it, but can not download and then use it.

    It does not show up among my applications. I can download it, but not open it.
     
  7. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    9
    Location:
    Glen Burnie, MD - USA
    Possibly. Isn't that the same phone as a T-Mobile Amaze? That would be over two years old. What version of Android are you running?
     
  8. Aovelto

    Joined:
    Jul 4, 2014
    Messages:
    8
    Likes Received:
    0
    The phone was released in 2010, and the version is 2.3.5. I know it's old, but is there a way to make it work?
     
  9. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    9
    Location:
    Glen Burnie, MD - USA
    I just checked as I used to have a T-Mobile Amaze. The Desire was HTC's mainstream model. I believe the Vision+ app requires you to have at least Android 4.x. Check for an updated version of Android for your phone. My Amaze was running 4.1 I believe but, since it was a T-Mobile phone, they controlled the updates. I no longer have my Amaze...gave it away to a friend who was still using an ancient flip phone. If your's was purchased directly from HTC or is an "unlocked" version, you will have to check with HTC (or the carrier from which your purchased it if it is locked) for an update. Google is funny about updating unlocked phones. If the phone is over 18 months old, they usually don't supply updates. Carriers vary depending on the popularity of the model.
     
  10. dragonash

    Joined:
    Mar 21, 2014
    Messages:
    906
    Likes Received:
    11
    Location:
    Brooklyn, NY
  11. SeeUAV

    Joined:
    Apr 12, 2014
    Messages:
    63
    Likes Received:
    0
    Location:
    Australia
    Have you have a look at the app called Market Enabler? Seems to let you trick it into thinking you have a different device. Allowing you to install apps not listed as compatible with your device.
     
  12. dragonash

    Joined:
    Mar 21, 2014
    Messages:
    906
    Likes Received:
    11
    Location:
    Brooklyn, NY

    that wont work.
    he tried to side load it already. His OS is just too old and doesnt support the app. He needs to upgrade