Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Tags:
  1. andy869

    Joined:
    Oct 9, 2016
    Messages:
    12
    Likes Received:
    2
    I've tried installing two different modules now in my P4 controller, and I never get the firmware update option. It won't even connect to the drone once installed , unless I pull the back cover off (and disengage the hdmi).

    Is there a way to force a controller update?
     
  2. RémyHeli

    Joined:
    May 23, 2016
    Messages:
    401
    Likes Received:
    60
    Did you make sure to install back the three ribbon cables and secured them with the three tiny lockers?

    You probably did, but look at this video where the guy doesn't show how to put back the ribbons on the new board. For me this is misleading..





    Sent from my iPhone using PhantomPilots
     
  3. andy869

    Joined:
    Oct 9, 2016
    Messages:
    12
    Likes Received:
    2
    Yeah, I was very careful putting all the ribbons back in. I did it and re-did it multiple times with different modules.

    At this point I am getting no communication to the bird, and no options for firmware downloading. Forcing a firmware download I am prompted to select "NONE" for firmware updates.

    With the back part of the module off, everything is normal (except hdmi of course)
     
  4. andy869

    Joined:
    Oct 9, 2016
    Messages:
    12
    Likes Received:
    2
    Pulling off the back of the module, I now can see firmware updates and it connects to the bird, however the only firmware option is a downgrade.
     
  5. andy869

    Joined:
    Oct 9, 2016
    Messages:
    12
    Likes Received:
    2
    I tried installing the firmware, it just sits and beeps at 0%. Installed my old board and the same thing. Did I just brick my controller? So frustrated, this should be simple and I just wasted 3 hours.


    Ok, got my old module back in, everything works.

    I just don't get it. I've tried two HDMI modules now and neither work.
     
    #5 andy869, Oct 9, 2016
    Last edited: Oct 9, 2016
  6. RémyHeli

    Joined:
    May 23, 2016
    Messages:
    401
    Likes Received:
    60
    #6 RémyHeli, Oct 10, 2016
    Last edited: Oct 10, 2016
  7. andy869

    Joined:
    Oct 9, 2016
    Messages:
    12
    Likes Received:
    2
    I fixed my issue, turns out the Ipad mini needed to be rebooted, the app wasn't working. When I used my Iphone to setup, everything worked fine.
     
    Emu and RémyHeli like this.
  8. RémyHeli

    Joined:
    May 23, 2016
    Messages:
    401
    Likes Received:
    60
    Thanks for this feedback, much appreciated.


    Sent from my iPhone using PhantomPilots
     
    andy869 likes this.