Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Standard Having trouble Getting going

Discussion in 'Phantom 3 Help' started by Capephan14, Jan 16, 2016.

  1. Capephan14

    Joined:
    Jan 16, 2016
    Messages:
    1
    Likes Received:
    0
    I bought a Phanthom 3 standard and I am having trouble, I cant seem to get it calibrated. And I cant get it in safe to fly mode.
    My aircraft status on my I phone 5s shows
    Overall status: normal
    IMU normal
    Compass calibrate in the highlighted box I have tried on the driveway on the front lawn parking lot.Sometimes it will show the compass dial.Most times it will allow me to tap start or go. The light will show green on the unit.as I do my 360.
    Next my Gimball shows disconnected,
    but when I turn the dial on the controller the camera will move.
    On my home screen the block at the top center shows disconnected.
    Would it help to try another I phone?

    Can anyone help me get started?
    I am getting frustrated.
    I have downloaded the manual, but it is not much helpon the troubleshooting side.

    Thanks,
    Capephan14
     
  2. buford

    Joined:
    Sep 26, 2015
    Messages:
    757
    Likes Received:
    146
    What kind of phone or tablet?
     
  3. buford

    Joined:
    Sep 26, 2015
    Messages:
    757
    Likes Received:
    146
    Sorry, just seen you have an I phone. I'm an android user. know absolutely nothing about I phones.
     
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,073
    Likes Received:
    5,617
    Location:
    US
    Are you doing it properly?

     
  5. Caveman Bruce

    Joined:
    Jan 20, 2016
    Messages:
    17
    Likes Received:
    6
    If you are still having issues you may need to reset the IMU and Gimbal using the DJI Go app again .


    Here is a link for you!



    Happy Flying!

    Bruce