Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Have I blown up my Immersion TX?

Discussion in 'FPV (First Person View)' started by b1nuzz, May 16, 2014.

  1. b1nuzz

    Joined:
    Apr 27, 2014
    Messages:
    61
    Likes Received:
    0
    Hi All,

    Came home today after flying in a rage as I had lost control of my X1 switch.

    Got the P2 out of the box, fired it up to calibrate, but forgot to attach the aerial.
    It was probably on for 3 or 4 minutes before I remembered. :(

    Plugged in and now i have no video.

    Is that it, game over? Or is there anything that can be done to save it?
    Thought I would ask before I sink more cash.

    Thanks.
     
  2. framedtrash

    Joined:
    May 9, 2014
    Messages:
    23
    Likes Received:
    0
    Yep you have burned it out
    Without the antenna attached all the energy has no where ti go so it just burns up the transmitter
    Never power a transmitter without amaerial attached
    Damage can be done very quickly
     
  3. b1nuzz

    Joined:
    Apr 27, 2014
    Messages:
    61
    Likes Received:
    0
    Amazingly, it's OK.
    I left it for a while and it's come back to life!

    Every now and then you get a little bit of joy!


    Sent from my iPhone using Tapatalk
     
  4. GhostMaster

    Joined:
    Dec 7, 2013
    Messages:
    793
    Likes Received:
    36
    Its not OK, test the range, you will get a very low range....

    Never ever turn on a video tx without antenna.