Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Had my first fly away today after updating to the latest firmware.

Discussion in 'Standard/4k Discussion' started by BeauS, Mar 21, 2016.

  1. BeauS

    Joined:
    Jan 3, 2016
    Messages:
    270
    Likes Received:
    36
    I got it home safe, and will research similar posts to figure out how this happened.

    One thing I noticed is there was no home point button in DJI Go. I found it in the settings, but either way RTH failed.

    I had it out to about 1000 feet, lost signal and the app completely disconnected. Had a red light on my remote control.

    I found it about 100ft in the air, tried to bring it closer to me and it shot off further away.

    Found it again and I tried to drop it down to manually land it, then took took off in the other direction and landed itself in the nearby field.

    I noticed just that back to red lights were blinking, does that indicate low battery or no connection to the remote control?
     
  2. BeauS

    Joined:
    Jan 3, 2016
    Messages:
    270
    Likes Received:
    36
  3. mdowney58

    Joined:
    Feb 15, 2016
    Messages:
    488
    Likes Received:
    112
    Location:
    Mountain City, TN
    I think you inquired about the missing home point icon in another thread.
    The newest version of the DJI Go app (2.7) removed it.

    Sent from my SM-N910V using Tapatalk
     
  4. Tarheal63

    Joined:
    Feb 4, 2016
    Messages:
    42
    Likes Received:
    18
    Location:
    Tennessee
    Wow, the speed was almost 40 MPH, that thing was moving right along. At what point did the odd behavior start?
     
  5. BeauS

    Joined:
    Jan 3, 2016
    Messages:
    270
    Likes Received:
    36
    At the very end at 3 minutes 2.8 seconds. My last flight range was 9,000ft out. Here, I lost signal at 1579.8ft and the app disconnected completely. Should I have tried to reconnect to the Phantom's Wi-Fi? The remote had a red light to the far left.
     
  6. Dal

    Dal

    Joined:
    Mar 13, 2016
    Messages:
    167
    Likes Received:
    28
    Did your home point record on take off?


    Sent from my iPhone using PhantomPilots mobile app
     
  7. Dal

    Dal

    Joined:
    Mar 13, 2016
    Messages:
    167
    Likes Received:
    28
    If it did. Then shutting off your Rc should have brought it back


    Sent from my iPhone using PhantomPilots mobile app
     
  8. BeauS

    Joined:
    Jan 3, 2016
    Messages:
    270
    Likes Received:
    36
    my home point did record on take off after updating it in the settings. Shutting off my RC did not bring it home, neither did toggling the S2 switch.
     
  9. Dal

    Dal

    Joined:
    Mar 13, 2016
    Messages:
    167
    Likes Received:
    28
    That's odd. I had a "disconnected" message yesterday 2000m away. closed the app and toggled S2 and it came backā€¦


    Sent from my iPhone using PhantomPilots mobile app