Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

H3-2d sparked and smoked on installation

Discussion in 'Zenmuse H3-2D GoPro Gimbal' started by jasond415, Apr 6, 2014.

  1. jasond415

    Joined:
    Mar 28, 2014
    Messages:
    8
    Likes Received:
    0
    I have a phantom fc40 which I installed the h3-2d gimble on today, I've watched the videos and new how to do it,I installed the upgrade kit (main board front led light and gimble switch) hooked up the 8 pin black cable and put it all back together setting up the gimble with my gopro3 silver, when I plugged in the phantom battery I noticed a weird noise coming from the gimble which started pointing downward and seemed like it wanted to keep turning then saw a spark and quite a bit of smoke came out of the tilting servo(up/down) I'm not sure what happened maybe when hooking the battery up it overloaded it but now when I reconnect the gimble it is not responsive just swings freely, any ideas?
     
  2. jasond415

    Joined:
    Mar 28, 2014
    Messages:
    8
    Likes Received:
    0
    Found the problem after taking off part of the servo case I noticed that the black power strip shorted, I'm guessing on the screw since there was more damage around that area, now need to find someone that can get me that part.
     
  3. jasond415

    Joined:
    Mar 28, 2014
    Messages:
    8
    Likes Received:
    0
    Does anyone know where I can get the gimble repaired or replacement parts?