Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

GPS Locking

Discussion in 'Phantom FC40 Discussion' started by schwahman, Aug 1, 2014.

  1. schwahman

    Joined:
    Jul 28, 2014
    Messages:
    16
    Likes Received:
    0
    Thought I would toss this up right quick as I am not sure whats going on. Just got my FC40 on tuesday. Love it, have about 10 flights in so far, no crashes (bought a cheap chinese parrot knock off to practice with before purchasing this) so flying that made this thing a breeze.

    Start up for me is as follows, connect camera, turn on remote, hook up battery, watch the pretty lights flash green and red :p until I have HL, compass setup (only two flights have been in same area), start the motors and let them run for about 5 seconds then up..

    Here is where the problem is, when I go about 4 ft off the ground, it drifts. I've let it go to make sure its not going to try to go back, and it will keep going in one direction until I correct it. I've taken it to about 10 ft and it will still do the same.. any ideas to what might cause this? There is no wind to cause it to do this and I do have both switches in the top position.
     
  2. lostkiwi

    Joined:
    Apr 4, 2014
    Messages:
    124
    Likes Received:
    0
    Location:
    UK
    Sounds like its in Atti mode and not GPS mode. When it does this what colour are the lights?
    Also before you take off do you get a set of rapid flashes from the green LED?
     
  3. schwahman

    Joined:
    Jul 28, 2014
    Messages:
    16
    Likes Received:
    0
    Its in GPS I do know that. I swithced to ATTI and it drifts faster.

    As for light sequence, I let it sit on the ground till i have no read and see the 20 green blinks then the green single after.
     
  4. Lonewolf

    Joined:
    Jun 3, 2014
    Messages:
    447
    Likes Received:
    108
    There are 2 sets of fast flashing green lights. Usually the first set tells you that HL has been recorded. The second set tells you that it has sufficient satellites for GPS. For drifting as you mentioned, it might be that you don't have a good compass calibration. I noted the very same thing happening to mine. Whereas, it would drift usually to the left or, I'd see a "toilet bowl" swirling of the craft when it was in hover.

    To correct both situations, I did the following. I found the "magnetic declination" for my area and then after allowing the phantom to go into it's normal setup routine for all the flashing lights, I toggled the GPS/ATTI switch several times then pointed the phantom's front, to my "magnetic declination" point. That's when I started to do the so-called, "Compass Dance." After that, I NEVER had a problem again with drifting or "toilet bowl" swirling again when it was in hover.

    Now I know they don't mention this in the instructions for setting up the compass calibration, but I found it to be VERY helpful in my situation. Hope it helps you and others as well.

    Try going to www.magnetic-declination.com to find yours.
     
  5. schwahman

    Joined:
    Jul 28, 2014
    Messages:
    16
    Likes Received:
    0
    Lonewolf - thank you for this, i will try it when i get home and see what happens. I just thought of this, read somewhere else about updating the firmware. I have yet to plug the phantom into my computer so I will try that tonight as well and see if this resolves.
     
  6. Lonewolf

    Joined:
    Jun 3, 2014
    Messages:
    447
    Likes Received:
    108
    You're entirely welcome. I am quite surprised you haven't had other issues with it seeing you haven't set it up on the computer or updated the firmware. It could have been a lot worse for you for not doing that first.

    A couple of points of interest when setting it up are:
    1. REMOVE the PROPS! You don't want an accidental take off in the house!
    2. Be sure to set it to "GO HOME AND LAND" (Found in the, "ADVANCED F/S tabs).
    3. Enable your "Home Lock, ATTI, and enable the 2nd ATTI to "FAILSAFE." (Found in the ADVANCED IOC tabs.)
    4. Limits! The defaults are for 2000 Meters! For both Altitude and Distance. Set these to much lower limits until you're more comfortable flying. By doing so, your Phantom will not go beyond your new lower settings.
    5. MOST IMPORTANT! When you upgrade the firmware, you'll find that it set your controller to, "PPM" for some unknown reason in the "BASIC" "RC" TAB. Reset this back to "D-BUSS"

    Have fun!
     
  7. Cajvol94

    Joined:
    Jun 30, 2014
    Messages:
    217
    Likes Received:
    0
    Mine acted like this at first but when I got it up in the air 30-40'(just 1 time) it was all good. Now I can crank er up and it hovers 6" of the ground.
     
  8. mikey

    Joined:
    Jun 17, 2014
    Messages:
    146
    Likes Received:
    6
    Can you fill me on on what the ppm and d-buss are (what the differences)

    This is something I haven't changed, and I don't even know what they mean or do..
     
  9. Lonewolf

    Joined:
    Jun 3, 2014
    Messages:
    447
    Likes Received:
    108
    "D-BUSS" is used for the controller that came with your Phantom. "PPM" is for "Pulse Position Modulation" receivers/transmitters. That's how data is sent to the servos. If you are using the controller that came with your Phantom, the "PPM" position switch in the NASAM Assistant will not work with it.