Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

GPS & HL Not Working... Help!

Discussion in 'Phantom 1 Help' started by flyingirish, Jan 13, 2014.

  1. flyingirish

    Joined:
    Dec 23, 2013
    Messages:
    6
    Likes Received:
    0
    Hey Guys,
    So I've been trying to get used to my new Phantom (new to me) and I've been having a serious issue with the GPS Attitude Mode and HomeLock IOC not working. I've posted a video of what occurs below. The Phantom flies correctly when in Attitidue Mode and CL but when I switch it from CL to GPS mode it takes off like a bat out of hell and the only way to get it out of heading that direction is to switch it back to CL. I can fight it while its still in GPS mode but as soon as I let go of the sticks it goes back onto its original path. Also, HL does not work and I have tested that at about 100ft out so that shouldn't be an issue with the 10m boundary. I have done the compass calibration, the software is all up to date, have done the advance calibration numerous times and all the numbers look good, turned on IOC, and have checked out the GPS antenna to see if there is any visible damage (which there is not) and all of the wires are connected since I get a full GPS signal from the LED in addition to the LED indicating that it has recorded a home position (series of green lights). I can't seem to make heads or tails of what is going on and what is causing the problem. Any help would be appreciated!!

    [youtube]http://youtu.be/XPu9so3fbD4[/youtube]
    http://youtu.be/XPu9so3fbD4
    I started out the flight in Attitude mode (orange single blinking light with full GPS) and then switched to GPS mode at the 0:03 mark at which point it took off the left until I switched it back to CL and was able to regain control. I redid the experiment at the 0:36 mark and it took off the in the forward/right direction. As you can see, once in CL it hovers and holds location fine as long as there is no wind.
     
  2. shortyuk

    Joined:
    Jan 8, 2014
    Messages:
    144
    Likes Received:
    3
    what are you flying, p1, p2, vision, are you in naza mode, or phantom, if naza, a second series of flashing greens indicates home position not the first series. After this you are looking at a compass gps calibration issue or a faulty compass or gps module, is the compass correct direction on the leg of the phantom etc
     
  3. flyingirish

    Joined:
    Dec 23, 2013
    Messages:
    6
    Likes Received:
    0
    I am flying the updated version of the Phantom 1 (1.1.1). I get the first and second series of green lights in a row prior to me flying it. From what I know the compass should be in the correct position on the leg (ie. its located on the lower end of the right rear skid). When I power up the Phantom it doesn't give any LED lights that the compass is out of error and the NAZA software doesn't show an issue either. When I opened up the Phantom I took a look at the actual GPS module and there wasn't any sign of damage/issues. From what I've experienced so far it leads me to believe a faulty GPS unit even though the Phantom is supposedly receiving enough satelites through the LED indicator lights.
     
  4. shortyuk

    Joined:
    Jan 8, 2014
    Messages:
    144
    Likes Received:
    3
    is the compass module pointing the right way, hope you sort it out
     
  5. flyingirish

    Joined:
    Dec 23, 2013
    Messages:
    6
    Likes Received:
    0
    From what I could tell. I'll take another look at it tonight to make sure. I would assume that if it was pointed in the wrong direction that the craft would always take off in the same direction once I put it into GPS Mode. In the video I am facing due west and the first time I put the Phantom into GPS mode it heads south while the second time it headed north.
     
  6. shortyuk

    Joined:
    Jan 8, 2014
    Messages:
    144
    Likes Received:
    3
    your probably right, its worth checking though. good luck