Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Goodluckbuy gimbal help!

Discussion in 'General Discussion' started by mlees, Mar 4, 2014.

  1. mlees

    Joined:
    Feb 22, 2014
    Messages:
    54
    Likes Received:
    0
    Hey Everyone

    I just received my goodluck buy gimbal and was watching install videos. It seems there are many iterations of this gimbal. Mine has 4 set (horizontally) and 3 sets (down) of pins on the front of the gimbal.

    It also has a balance charger on the rear of the gimbal.

    So, I hook up the battery to the rear balance charger plug on gimbal and it works fine and as expected without any tilt function.

    However, I am not having any luck with getting the tilt to work.

    I have the three wire lead which it came with hooked up to the naza f2 port (white wire on the bottom black on top, red unhooked), and I am not getting any tilt with the controller. I did connect to naza and enable gimble.

    Any thoughts??
     
  2. amrflyingdude

    Joined:
    Dec 18, 2013
    Messages:
    335
    Likes Received:
    0
    If you look at the gimbal tilt connector it has like you have said 6 pins. Your NAZA F2 bottom pin should go to the top left pin on your gimbal.

    If this is how you set it up and still does not work:

    - Check on NAZA software that when you move the lever on the back you se on the screen the lever moving as well, in other worlds check that the lever itself is transmitting

    - Go to the gimbal page and re set to default. There is a button for it. then re enable gimbal

    Mine was fairly easy to set up and works like a charm!
     
  3. mlees

    Joined:
    Feb 22, 2014
    Messages:
    54
    Likes Received:
    0
    Thanks for the reply. The control board ended up being defective...
     
  4. davemcm

    Joined:
    Feb 11, 2014
    Messages:
    266
    Likes Received:
    4
    Location:
    Scotland
    how did you find this out? are goodluckbuy going to replace it? :shock:
     
  5. mlees

    Joined:
    Feb 22, 2014
    Messages:
    54
    Likes Received:
    0
    Well there is supposed to be a blue led illuminated on the board that was not turning on.

    After about 30 email exchanges they offered to send me another board for 18 dollars... without the assurance that it would fix the problem...

    Instead I am returning the item and paying for return shipping "unless there is a QC problem". Pretty disappointing and frustrating working with the Chinese directly.
     
  6. davemcm

    Joined:
    Feb 11, 2014
    Messages:
    266
    Likes Received:
    4
    Location:
    Scotland

    i've had the exact same problem with mines and have been trying to deal with them but they aren't being very cooperative.
     
  7. rfernandez

    Joined:
    Jan 20, 2014
    Messages:
    373
    Likes Received:
    0
    If you paid with a CC then dispute the charges, Make sure you keep all emails. If you paid with Paypal you can dispute it with them and you will get your money back (if that is what you want).
     
  8. davemcm

    Joined:
    Feb 11, 2014
    Messages:
    266
    Likes Received:
    4
    Location:
    Scotland
    scratch that, they've just offered to send me new controller for it free via live chat right now :)