Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Standard good evening all can someone please assist me

Discussion in 'Phantom 3 Help' started by RANDADY, Apr 24, 2016.

  1. RANDADY

    Joined:
    Apr 24, 2016
    Messages:
    1
    Likes Received:
    0
    can someone please assist me just got p3 standard cant get it going keeps losing signal cant calibrate in middle of process signal drops can someone give me step by step instru and how to fix every error at each steps been trying for over two weeks now
     
  2. Carlo Napoli

    Joined:
    Apr 18, 2016
    Messages:
    167
    Likes Received:
    4
    What's it doing when you tube the TX on the the p3 how many green flag she's you get
    ?
     
  3. glord727

    Joined:
    Apr 24, 2016
    Messages:
    15
    Likes Received:
    8
    Location:
    Orlando Fl
    I seem to be having the same problem with my P3P. It does no want to go into camera mode when RC Is connected to my I-Pad, Android tablet or a Kendle Fire. Only thing it wants to connect to is my old Galaxy S phone. Phone has a tiny screen and I can't hardly see anything on it. I have been reading on this forum about problems with DJI GO with IOS systems. So I figure that could be the problem with I-Pad. Was not sure if android and kendle Fire was IOS?
     
  4. proudman

    Joined:
    Apr 25, 2016
    Messages:
    8
    Likes Received:
    5
    I had the same issue, but was ok after I updated the firmware the second time


    Sent from my iPhone using PhantomPilots mobile app