Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Goes left with H33d gimbal and Gopro camera fitted

Discussion in 'Zenmuse H3-2D GoPro Gimbal' started by Steven Gunn, Aug 22, 2015.

  1. Steven Gunn

    Joined:
    Aug 3, 2015
    Messages:
    11
    Likes Received:
    1
    Location:
    Kirkconnel, Dumfriesshire, UK
    Fitted my H33D gimbal and Gopro 3 camera. When I start up my P2 and take off, it takes it upon itself to fly left and backwards slightly. making it all but impossible for me to fly. Without the gimbal and gopro - it flies perfectly. I assume there is something to do with settings / balance ? Help please.
     
  2. noiseboy72

    Joined:
    Jul 13, 2014
    Messages:
    575
    Likes Received:
    17
    Location:
    Lincs, UK
    Very unusual. Try a full IMU calibration and check your GPS is working correctly.
     
  3. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,107
    Likes Received:
    405
    Location:
    Commerce Twp,MI
    Did you ever calibrate X1 control in both RC and P2 software? To calibrate X! in the P2 software the RC unit has to be turned on.
     
  4. Steven Gunn

    Joined:
    Aug 3, 2015
    Messages:
    11
    Likes Received:
    1
    Location:
    Kirkconnel, Dumfriesshire, UK
    All sorted. A recalibration seemed to do the trick. Now got an issue with my Black Pearl FPV unit not charging. Works when plugged into the main power - but not on battery. Been in touch with the supplier - hopefully get this sorted soon and I can get a fully functional set up on the go.