Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Go App wont download on additional devices

Discussion in 'General Discussion' started by HD Flyer, Jan 15, 2016.

  1. HD Flyer

    Joined:
    Jan 8, 2016
    Messages:
    4
    Likes Received:
    0
    Hello Everyone! Semi new to the forum. Got my Standard for Christmas and loving it. Already received my second one yesterday, the Advanced. My question is this. I have the app downloaded on my mobile device. I wanted to download the app on another tablet we have in the house however, when I download, the app says "Installed" however does not download, not showing in apps. The message says this app is compatible with your device and when I left click on that message, it reads the device is my original mobile device (shows model and make) that I downloaded on the other week. Any ideas why it will not download on this other tablet and how does it recognize my mobile device?
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,959
    Likes Received:
    5,581
    Location:
    US
    What kind of tablet do you have?
     
  3. HD Flyer

    Joined:
    Jan 8, 2016
    Messages:
    4
    Likes Received:
    0
    One is a kindle fire and the other is my laptop which is an Acer.
     
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,959
    Likes Received:
    5,581
    Location:
    US
    Neither of those devices are compatible with DJI GO. It would be best to use a device on this list.
     
  5. HD Flyer

    Joined:
    Jan 8, 2016
    Messages:
    4
    Likes Received:
    0
    Thanks and I appreciate your time.
     
  6. RodPad

    Joined:
    May 20, 2015
    Messages:
    2,641
    Likes Received:
    367
    Location:
    Pacific,NorthWet, 97031
    How do you install or use DJI Go on a Laptop?
     
  7. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,959
    Likes Received:
    5,581
    Location:
    US
    It's not compatible.