Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Go and Litchi conflict

Discussion in 'Phantom 3 Help' started by jjpetroski, Jul 14, 2016.

  1. jjpetroski

    Joined:
    May 16, 2015
    Messages:
    78
    Likes Received:
    5
    Replaced Pro gimbal with new Pro gimbal after crash. Standard install, reconnected wires, white cushions and all looks normal. Turn on and gimbal does it's tweets, centers as normal. Problem is no image on tablet in GO or Litchi programs. Get "disconnected" message. Remote starts up engines, so that's connected. Redid wire connections and still same issue. Originally this was going to be about no image after new gimbal, but then I noticed I could get an image in GO after stopping all programs on my Android and unplugging/replugging the USB to the tablet. I did notice this issue prior to my crash. So how do you handle tablet conflicts with the two programs? Seem you have to establish a new connection with both individually (like the other doesn't exist) in order to get video.
     
  2. K9DAVE

    Joined:
    Mar 29, 2016
    Messages:
    44
    Likes Received:
    8
    Location:
    UK
    There appears to be an issue with some android units running the latest os update (marshmallow) where litchi and go fight for the usb if installed together. I have a galaxy s5 which worked perfectly before the update with both installed but post update neither programme will connect. So in my case I just have litchi installed as I only use my phone for goggles.

    Sent from my SM-G925F using PhantomPilots mobile app
     
  3. jjpetroski

    Joined:
    May 16, 2015
    Messages:
    78
    Likes Received:
    5
    I think I'm running Kit Kat, but it seems like I'm not the only one. Dang... may have to separate the two.
     
  4. K9DAVE

    Joined:
    Mar 29, 2016
    Messages:
    44
    Likes Received:
    8
    Location:
    UK
    I think it this particular problem only affects some models. I have a nexus 7 with latest software and works perfectly with both installed. Go figure

    Sent from my SM-G925F using PhantomPilots mobile app
     
  5. rene van der meer

    Joined:
    Oct 16, 2015
    Messages:
    377
    Likes Received:
    70
    I just installed Litchi today for the first time.
    I couldn't connect Litchi. I had to change the DJI Go settings.
    Setting->Applications->DJI Go, clear standard settings

    If I turn on the RC and attach the USB cable, then the Phone (Samsung S6 Edge, Android 5.1.1) asks which app I want to run. This works for both.
    The only thing is that I now can't switch between both apps without removing the USB cable.
    Is there a solution for that as well?
     
  6. K9DAVE

    Joined:
    Mar 29, 2016
    Messages:
    44
    Likes Received:
    8
    Location:
    UK
    Only speaking for myself I have to do the same on my tablet. Close the programme that you are running disconnect the usb cable and reinsert you then get the choice again

    Sent from my SM-G925F using PhantomPilots mobile app