Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Gimble disconnected

Discussion in 'Phantom 3 Help' started by Allan8056, Jul 2, 2016.

  1. Allan8056

    Joined:
    Dec 30, 2015
    Messages:
    14
    Likes Received:
    3
    Location:
    West Chester, OH
    When my Phantom 3 Pro boots up the gimbal does its dance... looks good but NO Video and the unit displays G Disconnected. If I touch the camera it swing down and cannot be controlled by the RC. I have NO picture.... HELP!!
    One other symptom... When I turn off the Battery using the standard process click and release and click and hold the button down... now I have to do it twice to turn off the unit. The RC works fine.
     
    #1 Allan8056, Jul 2, 2016
    Last edited: Jul 2, 2016
  2. Ghost Rider

    Joined:
    Apr 5, 2016
    Messages:
    319
    Likes Received:
    87
    Re calibrate everything. Make sure (which you probably did) the firmware is up to date. Other than that, I don't know what to tell you. If it hasn't been crashed, I don't know.
     
  3. Allan8056

    Joined:
    Dec 30, 2015
    Messages:
    14
    Likes Received:
    3
    Location:
    West Chester, OH
    Will do... Thanks for the suggestion! Have a Great 4th of July!
     
  4. tpuerzer

    Joined:
    Jul 17, 2016
    Messages:
    2
    Likes Received:
    0
    I had the same problem yesterday. I followed the directions on a YouTube video on how to remove the camera/gimbal assembly and after doing so I was able to disconnect and then reconnect the two ribbon cables and then replace the gimbal assembly. I also used the edge of a plastic drinking straw to gently push in the connector for the thin black ribbon cable. After doing that that everything worked again - so I assume it was simply a connection problem with one of the two gray cables. (Visually everything looked ok, so it must be really fussy about the cable connections).

    Hope this helps someone else avoid sending their unit in for repairs.