Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

gimbal twitched only in flight

Discussion in 'Zenmuse H3-3D/H4-3D GoPro Gimbal' started by HJBateau, Dec 14, 2014.

  1. HJBateau

    Joined:
    Dec 14, 2014
    Messages:
    2
    Likes Received:
    0
    Hi everybody,

    I just bought a phantom 2 incl h3-3d gimbal. Gopro 3+ installed. afterwards installed drivers and most recent firmwares. And now the issue; when the drone is starting everything seems fine. the gimbal calibrates and stops facing down. It's time to start the rotors.. gimbal still answers my controls (when moving it up and down etc. ) But when in flight the gimbal is not responding smooth and just jumping after seconds regarding my instructions. Also, the gimbal is continuesly (every 2 seconds) sort of twitching up and down (in a vertical way always, but sometimes also horizontally). I tried everything, reinstalling firmwares, other h3-3b rubbers (maybe this is caused by vibrations or something), adjust gains, start up in an northern direction..

    I dont have an anti interference board on it; can it help? I dont think if Im looking to the technical purpose of it.. Anyone an idea??

    Thanks a lot for your time in advance!
     
  2. HJBateau

    Joined:
    Dec 14, 2014
    Messages:
    2
    Likes Received:
    0
    Hi all,

    today I went to the dealer back and I received a new H3-3D to try. Problems solved! No more twitching, total stability now. :)
     
  3. createthis

    Joined:
    Dec 3, 2014
    Messages:
    11
    Likes Received:
    0
    Well, that's not what I wanted to hear. Mine is doing the same thing: http://youtu.be/g-3bCll-n6U

    I am using the FPV Plug and Play Adapter from KumbaCam and their instructions said to not use the anti-interference board, so the flight in the video was without it. I've since installed it. I'm not sure it helps though. Still seems to be suffering from the same problem while hovering with the camera aimed down at an angle.

    I did my best to balance the Hero 4 Black. I stuck a penny to the motor and it seems pretty well balanced side to side now. Still using the white rubber bushings.

    Any ideas short of sending it back to Amazon?
     
  4. createthis

    Joined:
    Dec 3, 2014
    Messages:
    11
    Likes Received:
    0
    I figured out what was causing my vertical twitch. Here's how I fixed it: http://youtu.be/6MmoqGoZyMM

    [youtube]http://youtu.be/6MmoqGoZyMM[/youtube] <--- not sure why that doesn't work here.