Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Gimbal tilt not workin

Discussion in 'Phantom 2 Discussion' started by Crazykaktus, Dec 12, 2014.

  1. Crazykaktus

    Joined:
    Mar 13, 2014
    Messages:
    62
    Likes Received:
    0
    Hey all

    Ok, puzzling situation here.... X1 switch working fine.... All going well... Do one flight and the tilt starts getting sticky.. Only gives a bit of movement... Then it goes completely...... So I plug into the RC2 software and yep it would seem the pod on the radio has gone... It moves a bit then nothing .... Then with full left or right - then nothing...

    SO I get a 5k Pod do the mod thing - Now its just dead... Nada - Zippo.... Can even get it to budge a bit... I tested the pod... Works fine.... I noticed there is a little push button on the board in the radio.... ?! A reset switch perhaps...

    Any suggestions... ?

    Ive been having thoughts on replacing the DJI radio and getting The Terranis FRsky X9D - Any one modded and fitted this radio to a phantom 2 ?!?! Advice
     
  2. pilsburypie

    Joined:
    Jul 18, 2014
    Messages:
    160
    Likes Received:
    2
    Location:
    Birmingham, UK
    Have you done a full IMU calibration. My X1 was playing up and I calibrated the controller loads with no luck. Did IMU calibration then all was fine
     
  3. ussvertigo

    Joined:
    Jan 28, 2014
    Messages:
    333
    Likes Received:
    68
    Location:
    South Georgia
    Might have to do cal back and forth a time or two between Phantom Asst. and RC asst. It finally got mina going.