Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Gimbal Roll Bug in New Firmware?

Discussion in 'Firmware' started by Domenic, Sep 8, 2015.

  1. Domenic

    Joined:
    Jul 15, 2015
    Messages:
    36
    Likes Received:
    23
    Just updated to the new 1.4 firmware yesterday and noticed something different today that I never experienced before regarding how the gimbal was operating. Worked fine (or behaved the same way) for months prior to yesterday and fine all day yesterday with the new firmware. Just today during my first flight that I noticed this (video 1). I then turned everything off - rebooted essentially - and took the second video where everything seemed to be normal.

    Example Videos:

    Video 1 - horizontal movement fast and slow to the right and left. Gimbal seems to be malfunctioning.


    Video 2 - horizontal movement fast and slow to the right and left. Gimbal seems to be OK.



    Do you think this was a fluke? Maybe a setting I inadvertently set wrong? Maybe a bug in the new firmware? Anyone ever notice such a malfunction or "feature" ever?

    DOM
     
  2. envisionabove

    Joined:
    Apr 13, 2015
    Messages:
    1,036
    Likes Received:
    387
    Location:
    Tim in San Diego
    Are you in follow setting? Or FPV?
     
    skyhighdiver likes this.
  3. Oso

    Oso

    Joined:
    May 19, 2015
    Messages:
    2,533
    Likes Received:
    1,480
    Location:
    Sacramento CA
    Follow mode vs FPV mode?
     
    skyhighdiver likes this.
  4. brianb87

    Joined:
    Aug 21, 2015
    Messages:
    788
    Likes Received:
    148
    That is not correct. Maybe a gimbal calibration? Someone else with more experience might be more helpful.
     
  5. leekiya

    Joined:
    Aug 29, 2014
    Messages:
    1,103
    Likes Received:
    145
    Location:
    Lee. UK
    The gimbal seems to be set to fpv, just check it's not in the settings. Hope it's just something as simple as that for ya.
     
  6. bartold

    Joined:
    Apr 13, 2015
    Messages:
    179
    Likes Received:
    31
    I have to agree with all but post 4.
     
  7. brianb87

    Joined:
    Aug 21, 2015
    Messages:
    788
    Likes Received:
    148
    Lol! That's why I said ask someone with more experience! Just tryin to help a brotha out.
     
  8. Frans Nobel

    Joined:
    Aug 2, 2015
    Messages:
    29
    Likes Received:
    7
    Location:
    The Netherlands
    First video is FPV, video2 is Follow.
     
  9. Roderick Finch

    Joined:
    May 17, 2015
    Messages:
    3
    Likes Received:
    0
    I had the same problem yesterday, I did a calibration and it was fine after that.
     
  10. Domenic

    Joined:
    Jul 15, 2015
    Messages:
    36
    Likes Received:
    23
    I never touched any other settings or the PAF button (in the P position both times) on the controller between videos. I just rebooted the bird & restarted the app.
     
  11. bartold

    Joined:
    Apr 13, 2015
    Messages:
    179
    Likes Received:
    31

    My apologies. I thought you were saying everyone was incorrect. I guess you meant that the videos were not correct.
     
  12. brianb87

    Joined:
    Aug 21, 2015
    Messages:
    788
    Likes Received:
    148

    Correct, the video did not look right...Not a problem! I should have made it more clear.
     
  13. Altanore

    Joined:
    Jun 4, 2015
    Messages:
    118
    Likes Received:
    36
    Location:
    AB, Canada
    In video 1, the setting had to be in FPV mode. The app is known to change settings on it's own without you touching them. Happened to me once. That's why it is always a good idea to check them all including the failsafe settings before flying.
     
    skyhighdiver likes this.
  14. LuvMyTJ

    LuvMyTJ ADMINISTRATOR
    Staff Member

    Joined:
    Feb 9, 2014
    Messages:
    6,811
    Likes Received:
    4,375
    Location:
    Live! From New York!
  15. Viral

    Joined:
    Jul 26, 2015
    Messages:
    104
    Likes Received:
    58
    Your bird switched from Follow mode to FPV, no question. If you've never used it, that's exactly how it works. Mine has switched modes on its own a few times as have many others on here. Just switch it back and you should be good.
     
    skyhighdiver likes this.
  16. Domenic

    Joined:
    Jul 15, 2015
    Messages:
    36
    Likes Received:
    23
    UPDATE:

    I have 100% confirmed this is a bug. Today I just turned the P3 on and you can see what is going on in this video:



    By just rebooting the quad it goes back to normal.

     
  17. louforgiveno

    Joined:
    Jan 16, 2015
    Messages:
    644
    Likes Received:
    251
    Fyi, the one of the buttons on the bottom of the contoller is defaulted to switch modes when tapped.....are you maybe accidentally hitting that?
     
  18. Domenic

    Joined:
    Jul 15, 2015
    Messages:
    36
    Likes Received:
    23
    When I shot the two quick videos above I only rebooted the P3 and didn't touch any buttons on the controller. Just moved the stick after it reconnected.
     
  19. JohnK

    Joined:
    Jun 4, 2015
    Messages:
    512
    Likes Received:
    169
    Location:
    Hudson Valley, New York
    @Domenic have you checked the FPV vs Follow mode setting? You have made no mention of it, but seems to be the obvious first place to look, especially with lou's observation about the buttons.

    The FAP switch has nothing to do with this.
     
    louforgiveno likes this.
  20. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    The RH side (probably) rocker switch underneath defaults to FPV or Follow and it can change back to defaults after firmware updates..
    FPV mode is supposed to give more of the feeling of banking as you zoom about, you rarely see it used in P3 videos.

    You need a proper test outdoors after ensuring it is set in Follow either from the app or switch.
    The switch is probably best set to change between Map and Camera.

    .