Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Gimbal Problem

Discussion in 'Zenmuse H3-3D/H4-3D GoPro Gimbal' started by zeppelin390, Feb 5, 2015.

  1. zeppelin390

    Joined:
    Feb 5, 2015
    Messages:
    6
    Likes Received:
    0
    At start-up, the gimbal goes through the full range of motions during its initial checklist, then goes to about a 45 degree angle facing forward. After this when I move the X1 dial, I get only a limited range of motion from the gimbal. I have done the factory reset of the gimbal, calibrated and recalibrated the RC, all of which have produced no better results.
    Suggestions?
     
  2. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,413
    Likes Received:
    567
    Location:
    Sydney Australia
    Phantom assist > BAsic > RC = select "upgrade mode" (this is for the tilt to NOT return to 45 when the dial is released).

    Then Phantom Assist > Advance > Gimbal (this is to set the range of movement. The tilt gains will NOT work)
    Gain = Any number
    Horizontal = 0
    Vertical = 0
    (I cant remember, but I think I set mine to minus 10 or 15 of horizontal so you don't see the props in wide and medium FOV).
     
  3. Prophecies

    Joined:
    Jan 28, 2015
    Messages:
    63
    Likes Received:
    1
    Location:
    Montreal, Canada
    When calibrating the RC, make sure you calibrate the X1 dial. Mine was doing exactly this, and it turns out I didn't realize the X1 tilt dial needed calibration as well. Update the firmware for the gimbal, and calibrate the RC and you should be set.

    One thing I have noticed though, is once it is done with its start up, it will by default start off in the 45° position. I just tilt it up or down and it works fine with no issues at all, it's just the default starting position that bugs me. Id want it to default facing forward, but it's not much of a problem. Anyone know what to do in that situation?
     
  4. zeppelin390

    Joined:
    Feb 5, 2015
    Messages:
    6
    Likes Received:
    0
    You nailed it...my horizontal and vertical limits were all the way to the left. I changed them to 0 and now have full control over the gimbal. Another issue has occured though, when the gimbal is all the way up facing forward, the motors activate and appear to be trying to position itself at an angle it cannot achieve. As soon as i dial it down a little, it stops.
     
  5. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,413
    Likes Received:
    567
    Location:
    Sydney Australia
    Change either the horizontal or vert to minus 10 to limit its movement. Just mess with the settings whilst you have the phantom assist plugged in.