Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. marcel79

    Joined:
    Aug 1, 2016
    Messages:
    34
    Likes Received:
    10
    Hello,
    Love flying drones, and for me the p4 is the first that i can fly for months without having some sort of a problem with it
    Untill yesterday that is, i just started a flight at a nice location, but as soon as it was in the air, i couldn't switch between camera and photo, and i couldn't started a recording.
    Then i landed and restarted the drone, rc and go app, and from then i have no video-feed and the status of my gimbal states; gimbal not connected.
    Everything looks good, never had a crash or problems with the p4 before.
    I am no tech so i dont prefer opening the phantom up, and the gimbal cable looks good.
    Also when i start it up, it still does the check and center it, but no feed and no gimbal connection.

    Do i have to send it back, or some sort of firmware problem?

    The weather is getting great out here;) so hopefully someone can help..
    Greetz Marcel
     
  2. marcel79

    Joined:
    Aug 1, 2016
    Messages:
    34
    Likes Received:
    10
  3. gvhogsett

    Joined:
    Jul 20, 2016
    Messages:
    2
    Likes Received:
    0
    It did it to me had to reformat my sd card be sure to do it in the app hope it helps
     
  4. marcel79

    Joined:
    Aug 1, 2016
    Messages:
    34
    Likes Received:
    10
    Ok, thanx for the possible solution, i will try it after work today.

    Sent from my SM-G920F using PhantomPilots mobile app
     
  5. marcel79

    Joined:
    Aug 1, 2016
    Messages:
    34
    Likes Received:
    10
    Thanx gvhogsett! After formatting the sd from within the dji app is suddenly got my video feedback thanx again!

    Sent from my SM-G920F using PhantomPilots mobile app
     
  6. gvhogsett

    Joined:
    Jul 20, 2016
    Messages:
    2
    Likes Received:
    0
    I'm glad it helped