Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Gimbal motor stops after 3-4 minutes into the flight

Discussion in 'Standard/4k Discussion' started by Xardinen, Sep 22, 2016.

  1. Xardinen

    Joined:
    Sep 22, 2016
    Messages:
    2
    Likes Received:
    0
    I have a problem with a gimbal motor that stops working when I've been flying for a couple of minutes. Does anyone have any experience of a similar issue?
     
  2. Ted4797

    Joined:
    Nov 23, 2015
    Messages:
    972
    Likes Received:
    155
    Location:
    Florida
    any hard landings?
     
  3. sinxa

    Joined:
    Sep 2, 2016
    Messages:
    183
    Likes Received:
    38
    when it happen, any error message?
    is the camera stay at last position or going limp?
     
  4. TWebb

    Joined:
    Dec 20, 2015
    Messages:
    84
    Likes Received:
    6
    I have almost same issue. Fired it up, camera is limp and in settings says gimbal disconnected. Flight before,all was fine. Very sad, as I was on vaca in the woods.


    Sent from my iPhone using PhantomPilots
     
  5. John Locke

    Joined:
    Jun 26, 2015
    Messages:
    2,903
    Likes Received:
    1,095
    Location:
    Yorba Linda, CA
    What changes have you made to your OS, firmware or Go application recently?
     
  6. Xardinen

    Joined:
    Sep 22, 2016
    Messages:
    2
    Likes Received:
    0
    The problem was present stock from the store.
     
  7. John Locke

    Joined:
    Jun 26, 2015
    Messages:
    2,903
    Likes Received:
    1,095
    Location:
    Yorba Linda, CA
    Return it for an exchange, is it too late?

    If nothing physical happened to the craft, you can try the following:

    1. See if Go will recalbrate the gimbal. (this might not work if it's truly disconnected)
    2. Recalibrate the IMU. Unlikely the issue, but easy to do. The gimbal should go through an exercise.
    3. Check the flex cable from gimbal to insure nothing is damaged somehow.
    4. Delete Go and reload the app onto your smart device.
    5. Find a friend with a P3 and link the craft to his controller to see if the same issue occurs.
     
    #7 John Locke, Sep 23, 2016
    Last edited: Sep 23, 2016