Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional "Gimbal Motor Overloaded" warning when going all the way left.

Discussion in 'Phantom 3 Help' started by Bratinov, Jun 29, 2015.

  1. Bratinov

    Apr 5, 2015
    Likes Received:
    I get this when fully going left (right stick all the way left) :(
    This is in follow mode.
    Going all the way in any other direction gives no warning.

    This is rather upsetting, you would think the gimbal could handle any of the craft's movements as long as there is no wind...
    No performance difference, warning or not.
    #1 Bratinov, Jun 29, 2015
    Last edited: Jun 29, 2015
  2. J.James

    Apr 21, 2014
    Likes Received:
    Upstate NY
    mine was doing all sorts of weird stuff like that after the last firmware update. The gimble would lose center and drift to the left on its own even when it was just sitting on the kitchen table. or if flying and not putting any yaw in to it when flying straight for about 30 seconds. But it going off center and not being zeroed after drifting to the extreme left was also causing it to hit the stops and would hop every time it hit the stop thingy on the arm any time the gimbal needed to move its self to the left to counter any movements of the phantom. it would also pop up a gimbal motor overload message on the screen any time it would hit the stop and hop around.
    I tried a compass calibration and a few IMU calibrations with no luck. and I ended up having to do a compass calibration AFTER the imu and also needed to do the compass calibration in a different location. Now its working right again after the last compass calibration.

    So im pretty sure its some thing to do more with the compass then the IMU thats causing the gimbals problems many seem to be havering sence the last firmware update.
  3. Steve101

    May 15, 2015
    Likes Received:
    I have been getting gimbal motor overloaded recently. I got it with and without the filter attached.

    Having an ND filter is necessary. The video is jumpy and unusable without.

    I have firmware 1.1.9