Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Gimbal gurus : help me, You're my only hope

Discussion in 'Phantom 3 Help' started by jordanwilliam23, Oct 29, 2015.

  1. jordanwilliam23

    Joined:
    Aug 29, 2015
    Messages:
    68
    Likes Received:
    9
    Bought a new ribbon cable and part 42, Put it altogether, now the gimbal and camera turn on, rotate ,move a little bitand during this time I can use the gimbal wheel on the controller to move it up and down, Then after 10 seconds it just goes flat and dies.The app says the gimbal is working properly but it's not working at all. What is the diagnosis?
     
  2. hunch

    Joined:
    Oct 10, 2014
    Messages:
    1,500
    Likes Received:
    225
    let me guess, you purchased a cable from amazon or atkdrones or is it genuine DJI cable?

    first two there's a good chance they won't work. DJI genuine works every time.
     
  3. jordanwilliam23

    Joined:
    Aug 29, 2015
    Messages:
    68
    Likes Received:
    9
    Dji through DJI approved distributor
     
  4. jordanwilliam23

    Joined:
    Aug 29, 2015
    Messages:
    68
    Likes Received:
    9
    Dji ImageUploadedByPhantomPilots - DJI Phantom Forum1446151125.246075.jpg ImageUploadedByPhantomPilots - DJI Phantom Forum1446151136.528679.jpg

    This says there is that HD video image transmission connection, you buddy have any idea what's going on why it's dying 10 seconds into turning on, hunch, I heard you were the master
     
  5. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Try reformatting you SD card.. A bad format on that card will affect the camera and the gimbal.
     
  6. hunch

    Joined:
    Oct 10, 2014
    Messages:
    1,500
    Likes Received:
    225
    registration problem.
    in most cases, bad cable but could be just a connection issue at this point.
    both sensor boards (P and R), main board and camera module all have plastic tabs on the connectors correct?
    none of them are broken off or missing?
    if yes then that is your issue.
    if not, reconnect them all and reconnect the two grey cables coming from the bird into the gimbal.
     
  7. hunch

    Joined:
    Oct 10, 2014
    Messages:
    1,500
    Likes Received:
    225
    also, why is the image so red? something is not right still.
     
  8. jordanwilliam23

    Joined:
    Aug 29, 2015
    Messages:
    68
    Likes Received:
    9
    Lol, I think it's because I'm in a registered no-fly zone
     
  9. ATKdrones

    Joined:
    Sep 14, 2014
    Messages:
    2
    Likes Received:
    0

    Hunch is incorrect, DJI cables can also fail, the difference is, ATKdrones stands behind the purchase, if for any reason an ATK cable fails when properly installed, it will be replaced immediately.

    There has been a rare problem with the camera ribbon cable connector registration. It's because of a variance in the manufacture of the ribbon cable connectors that DJI used and it very easy to verify by examining the ribbon cable under a microscope. Simply look at the divots in the ribbon cable at the camera connector end, if any missed the ribbon cable pads, then it's a connector-ribbon cable registration problem. It is also possible the the ribbon cable connector tension bar wasn't properly re-seated.

    In these rare ribbon cable alignment cases, it can be determined if a swap of the ribbon cable will likely solve the problem due to the ribbon cable connectors unique alignment, and can be solved by selecting a ribbon cable with the appropriate registration, or in some cases, it's also possible that the ribbon cable connector could be damaged, in that case, the cameras ribbon cable connector can be replaced at ATKdrones at a fraction of the cost of a new gimbal.