Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Gimbal engine overload + compass error

Discussion in 'Pro/Adv Discussion' started by Chengdu Rafael, Sep 30, 2016.

  1. Chengdu Rafael

    Joined:
    Sep 30, 2016
    Messages:
    8
    Likes Received:
    0
    I just had a scary flight and would like to ask for help. this is near the 100th flight on my Phantom 3 Pro but first time in Budapest.
    Right before taking off an error `gimbal engine overload' showed up, which disappeared after moving the drone and compass calibration. Never had this message before and not sure what it means.
    Once airborne, in less than a minute after only 2 shots at 50 meters height it started `weak GPS signal`, i started descent. I got a `Warning. Compass Error. Exit GPS-P mode'. I did not exit P-mode. Then the drone seemed to lose control and fly away which was really scary, i quickly started to take it down and I had to control its direction to move back, but for a few seconds it was moving uncontrollable.
    Please advise, here is the HD log for this flight: HealthyDrones.com - Innovative flight data analysis that matters
    Thanks for any help, hope to take more shots during this trip...
     
  2. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,152
    Likes Received:
    1,664
    Location:
    San Francisco, CA
    Gimbal overload error is a very common error when Gimbal gets restricted from moving left right up down during initialization. Sometimes it happens if one forgets to remove the Gimbal protective lens cover or when one takes off say from grass.

    There is not much seen on your logs. I feel the main cause of the error was that you lost GPS satellites. I may be wrong.


    Sent from my iPhone using PhantomPilots
     
  3. Chengdu Rafael

    Joined:
    Sep 30, 2016
    Messages:
    8
    Likes Received:
    0
    Thanks! i was taking of from grass so it explains the gimbal overload error...
    As I see in the log GPS signal and compass show just fine throughout the flight, the only thing odd is seen from Notifications :

    Flight time Altitude Home Distance Type Notification
    A 00m 00s 0.0 ft 0 ft Mode Mode changed to GPS_Atti
    B 00m 02s 0.0 ft 0 ft Mode Mode changed to AssitedTakeoff
    C 00m 06s 0.0 ft 0 ft Mode Mode changed to GPS_Atti
    D 00m 42s 93.2 ft 62 ft Mode Mode changed to Atti
    E 00m 42s 93.2 ft 62 ft Warning Warning:Compass Error. Exit P-GPS Mode
    F 00m 43s 93.2 ft 61 ft Mode Mode changed to GPS_Atti

    Why would Mode change to Atti (no GPS) ? I did not change it...


     
  4. GMack

    Joined:
    Jul 26, 2016
    Messages:
    581
    Likes Received:
    147
    Do you have another battery to try? If you look at your data, the third cell is different than the others so maybe something going on there. It's still in the green, but higher than the others which are at zero. Might also do a recal of the compass and IMU too.

    As for the gimbal, did you have a push-on or heavy filter on the camera? I have a few push-ons that are heavy, but mine seems to result in differing horizon tilts when I yaw or brake quickly and the tilt changes maybe due to the weight of the filter. Haven't noticed a pop-up warning about a gimbal overload though.
     
  5. Chengdu Rafael

    Joined:
    Sep 30, 2016
    Messages:
    8
    Likes Received:
    0
    Thanks, I will choose a good location with the other battery and flat surface to calibrate both IMU and compass. I hope battery does not cause loss of control mid-flight though.
    I think for the gimbal the grass was the issue, as I was taking off from grass.

     
  6. Chengdu Rafael

    Joined:
    Sep 30, 2016
    Messages:
    8
    Likes Received:
    0
    A more important question would be: in such situation, what is the right thing to do? Exit GPS-P Mode or not? Switching to A means gaining back control? What made it scary was not knowing the best option.
    Thanks~!!
     
  7. Numone

    Joined:
    Jan 10, 2016
    Messages:
    888
    Likes Received:
    240
    Location:
    Surrey, England
    Yes, exit "P" mode and into "A". That defeats the GPS and allows you to bring the AC back to you. I suggest you practice flying in "A" mode as often as possible in case you encounter this type of problem again. It's happened to me once; that was enough of a scare for me to learn "proper" control without GPS assistance.
     
  8. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,152
    Likes Received:
    1,664
    Location:
    San Francisco, CA
    Phantom changes to ATTI mode on its own only when it sees low number of satellites. So the logs is showing that somehow aircraft could not get the required number of minimum satellites and switched to ATTI mode where ones skills are used to get the bird back to stable state. Were you closer to high rise buildings or very heavy electrical noise....? Or it could be a malfunctioning of GPS system of your phantom which could be scary as it can happen again.


    Sent from my iPhone using PhantomPilots
     
  9. Pharm

    Joined:
    Jun 14, 2016
    Messages:
    747
    Likes Received:
    272
    No need to switch to atti mode when it says " Exit P-GPS Mode". By exiting, it's already switched to atti mode on it's own.
     
  10. Chengdu Rafael

    Joined:
    Sep 30, 2016
    Messages:
    8
    Likes Received:
    0
    I found there is a 132/10 kV substation within 500 meters... that could have been the cause.
    Hope it will not happen again especially close to trees/buildings.

    QUOTE="alokbhargava, post: 948567, member: 38561"]Phantom changes to ATTI mode on its own only when it sees low number of satellites. So the logs is showing that somehow aircraft could not get the required number of minimum satellites and switched to ATTI mode where ones skills are used to get the bird back to stable state. Were you closer to high rise buildings or very heavy electrical noise....? Or it could be a malfunctioning of GPS system of your phantom which could be scary as it can happen again.


    Sent from my iPhone using PhantomPilots[/QUOTE]
     
  11. jephoto

    Joined:
    Jun 15, 2015
    Messages:
    555
    Likes Received:
    179
    Actually I'm not sure that's true- if the P3 starts acting erratically & out of control he really DOES want to switch to ATTI to keep it from flying away or crashing into something.
    Had this happen to me last month when setting off not far from a bunch of high rise buildings- lots of interference- and my P3 started accelerating and flying very erratic. I almost lost control- speeding up in wider and wider circles as I tried to bring it back.
    Then my friend yelled- "put it in AttiMode" and I did- and it immediately stopped its zooming around. I was able to bring it back to me- of course having to counteract the wind as I did- but I got it home.
    It was pretty scary. I thought it would either fly away over the lake (Michigan- very big...) or crash into one of the buildings nearby.
    Going to ATTI mode saved me.

    That's a different scenario than just not having enough satellites. The compass was getting bad info and was trying to act on it.


    Sent from my iPhone using PhantomPilots
     
  12. jephoto

    Joined:
    Jun 15, 2015
    Messages:
    555
    Likes Received:
    179
    But one does have to practice ATTI flying- when not in a crisis first- because without the GPS the wind will take you away too and you need to learn to really fly,compensating for wind.


    Sent from my iPhone using PhantomPilots
     
  13. Chengdu Rafael

    Joined:
    Sep 30, 2016
    Messages:
    8
    Likes Received:
    0
    Today I went to fly at a safe location with absolutely no interference, an island with lawn and park all around. Tried a different battery and did both IMU/compass calibration first.

    Now after few minutes again got the compass error / exit GPS-P warning. Luckily it happened while flying very near, I switched to ATTI and took it down.. In the next 2 flights the same happened, after few minutes, when I now managed to stabilize quickly and got the GPS back, then switch back to P mode and flied a little more without problem. It happens to occur quite often now. What can be wrong with the GPS system? Should i send it back to DJI?

    All through the flight I actually had 18 satellites and the HD log shows everything just perfect except for the notifications:

    Flight time Altitude Home Distance Type Notification
    A 02m 49s 0.0 ft 0 ft Mode Mode changed to GPS_Atti
    B 02m 51s 0.0 ft 0 ft Mode Mode changed to AssitedTakeoff
    C 02m 53s 0.0 ft 1 ft Mode Mode changed to GPS_Atti
    D 03m 12s 100.7 ft 15 ft Mode Mode changed to Atti
    E 03m 12s 100.7 ft 15 ft Warning Warning:Compass Error. Exit P-GPS Mode
    F 03m 13s 100.7 ft 18 ft Mode Mode changed to GPS_Atti
    G 03m 17s 98.8 ft 48 ft Mode Mode changed to Atti
    H 03m 18s 98.4 ft 49 ft Warning Flight Mode Set to Atti:Set flight mode to GPS to ensure safety.
    I 03m 33s 6.2 ft 6 ft Mode Mode changed to GPS_Atti
    J 07m 22s 96.8 ft 128 ft Mode Mode changed to Atti
    K 07m 22s 96.8 ft 128 ft Warning Warning:Compass Error. Exit P-GPS Mode
    L 07m 28s 90.2 ft 77 ft Warning Flight Mode Set to Atti:Set flight mode to GPS to ensure safety.
    M 07m 43s 38.1 ft 73 ft Mode Mode changed to GPS_Atti

    Thanks!
     
  14. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,152
    Likes Received:
    1,664
    Location:
    San Francisco, CA
    I was expecting the same behavior, good that you saved it.

    I am sure it needs an evaluation with DJI. You should provide all the details to them and state very clearly that though 18+ satellites are displayed, P3 switched to ATTI mode on its own.