Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Gimbal disconnected and no image transmission signal

Discussion in 'Pro/Adv Discussion' started by Great_Lakes, Sep 8, 2016.

  1. Great_Lakes

    Joined:
    Apr 22, 2016
    Messages:
    269
    Likes Received:
    70
    Location:
    South Eastern Michigan
    Ok, a couple of weeks ago I crashed into the house and broke the gimbal yaw arm. Replaced it. Replaced the ribbon cable.

    Now no image transmission signal and "Gimbal disconnected" I don't get it. Watch the video below. Perhaps one of you may see something that I am missing.

    Thanks for your help!

     
  2. hunch

    Joined:
    Oct 10, 2014
    Messages:
    1,500
    Likes Received:
    225
    did you buy the gimbal cable from a 3rd party or is it the original DJI part 49 ?
    if it's not original DJI most likely the cable, but could also be that the main board on the gimbal cooked - most common thing on P3P gimbals.
    is the fan on the upper case of the gimbal black or white?
     
  3. Great_Lakes

    Joined:
    Apr 22, 2016
    Messages:
    269
    Likes Received:
    70
    Location:
    South Eastern Michigan
    I need to make a correction. I replaced the gimbal roll arm, not the yaw arm.

    Hunch, Third party cable. The fan is white. That brings me to another question. the fan doesn't run. Is it supposed to run constantly, or is it thermostatically controlled?
     
    #3 Great_Lakes, Sep 8, 2016
    Last edited: Sep 8, 2016
  4. hunch

    Joined:
    Oct 10, 2014
    Messages:
    1,500
    Likes Received:
    225
    controlled, however as soon as you turn the bird on it will start spinning about 15 seconds into it and never stop which brings me to a conclusion
    that your gimbal main board is toast but i wouldn't rule out the possibility of the cable not being original and if that's the case i would try that first.
    green blinking light and then stopping is not normal either. it should blink couple times in the beginning and then go to blinking green if sd card is inserted
    or blinking red if there is no card in it.
     
  5. Great_Lakes

    Joined:
    Apr 22, 2016
    Messages:
    269
    Likes Received:
    70
    Location:
    South Eastern Michigan
    An important fact to add is that the camera was taking video when it crashed. I looked at the video afterwards, and while the phantom was laying on the ground it was still taking perfect video until I picked it up and turned it off. So it was working even after the crash! The only thing I've done is replace the roll arm and ribbon. So perhaps it is the 3rd party ribbon. Is that a logical conclusion?
     
  6. Traveler

    Joined:
    Nov 27, 2015
    Messages:
    376
    Likes Received:
    105
    Was it working after the repair and then failed or has it not worked sense the repair?
    I received a new but faulty 3rd party cable once and after they send another it was fine.
     
  7. Traveler

    Joined:
    Nov 27, 2015
    Messages:
    376
    Likes Received:
    105
    Hunch, what is the difference between the black vs white fan?
     
  8. Great_Lakes

    Joined:
    Apr 22, 2016
    Messages:
    269
    Likes Received:
    70
    Location:
    South Eastern Michigan
    It has not worked since the repair. I'm going to get another ribbon cable. This time DJI original. I bought based on price and I shouldn't have. The one I got was around $15. DJI wants $35. I just hope that is the answer.

    And yes Hunch, what is the difference between black vs white fan? :)
     
  9. Traveler

    Joined:
    Nov 27, 2015
    Messages:
    376
    Likes Received:
    105
    Search for Fan Color and you will see that it is just a different color. All the same according to the post.
     
  10. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,152
    Likes Received:
    1,664
    Location:
    San Francisco, CA
    Check also the grey cables to ensure they are well seated. Once they are properly connected, you should see fan rotating


    Sent from my iPhone using PhantomPilots
     
  11. Ed209

    Joined:
    Jul 27, 2015
    Messages:
    938
    Likes Received:
    423
    I'm dealing with the same issue with a DJI ribbon cable only my camera board light doesn't light up. I read that the fan doesn't turn on unless it's recording 4k. I tested on my other P3P and the fan does not turn on when it's booting up or sitting idle.

    I suspect fried board which seems to be quite common. What FW are you on?
     
  12. hunch

    Joined:
    Oct 10, 2014
    Messages:
    1,500
    Likes Received:
    225
    three different models of P3P gimbals exist. first version was with a black fan, second with white and 3 with beige. not sure what the actual difference is in gimbal itself but i do know that
    neither of those fan do anything to prevent burnouts of the gimbal video transmission inside the gimbal.
    like the old P2v+ Wifi units would burn out until DJI started listening to some of us and started perforating the aluminum case of the wifi unit.
    similar issue. all related to heat.
    that's why when you are upgrading the firmware on a P3P make sure you have a house fan blowing at the bird the whole time.
    that's when most of the burnouts happen.

    in your case i am leaning toward a 3rd part cable. get a DJI part 49 original cable. it should come in a DJI bag and use that.
     
  13. hunch

    Joined:
    Oct 10, 2014
    Messages:
    1,500
    Likes Received:
    225
    fan on a P3P gimbal should turn on about 15 seconds after you turn the bird on. if it doesn't then either bird is flashed with a P3A FW or something is wrong with the main board.
    you see, P3A gimbal doesn't have a fan so it doesn't have a software "switch" to turn the fan on/off so that could be a possibility
     
  14. Ed209

    Joined:
    Jul 27, 2015
    Messages:
    938
    Likes Received:
    423
    Interesting... My other P3P is on FW 1.4.0010 and has no issues...After I noticed the fan not running on the other P3P that I just rebuilt which is running 1.9.60, I checked the 1.4.0010 P3 and noticed it wasn't running either. I saw some posts where people said their fan wasn't running unless it was recording 4k.
     
    #14 Ed209, Sep 8, 2016
    Last edited: Sep 8, 2016
  15. Great_Lakes

    Joined:
    Apr 22, 2016
    Messages:
    269
    Likes Received:
    70
    Location:
    South Eastern Michigan
    One more question: It seems there are dozens of "Part 49 ribbon cables" for sale online. I can't seem to find one that says it is an original OEM part from DJI. I cannot even find it on the actual DJI website. (store) It has one for a phantom 4, but not the 3P. Does anyone know where I can find an original DJI flexible ribbon cable for the P3P?!!

    UPDATE: I swear it wasn't on the dji store 30 minutes ago but now it is! Ordering.
     
    #15 Great_Lakes, Sep 9, 2016
    Last edited: Sep 9, 2016
  16. Ed209

    Joined:
    Jul 27, 2015
    Messages:
    938
    Likes Received:
    423
    I ordered one from Amazon and it came loose in an electrostatic bag (no black DJI cardboard stapled to the top). It was from DJI on Amazon. I just ordered 2 more from B&H to repair more P3's with and I'll see how those come. B&H has always been good with authentic stuff. Help please Limp Gimbal/Camera
     
  17. Great_Lakes

    Joined:
    Apr 22, 2016
    Messages:
    269
    Likes Received:
    70
    Location:
    South Eastern Michigan
    I'm ordering the ribbon right from the dji store this time! With shipping it's $45.00! If this one doesn't correct the problem then I'll put my camera and gimbal up for sale and buy a new one!
     
  18. Ed209

    Joined:
    Jul 27, 2015
    Messages:
    938
    Likes Received:
    423
    B&H is free shipping for orders over $50 and they are super fast.
     
  19. flyNfrank

    Joined:
    Feb 1, 2014
    Messages:
    4,234
    Likes Received:
    915
    Location:
    Indy, USA
    When it comes to the flat ribbon cable you should always get the dji cable. It does not have to be bought from dji but as long as it is the actual oem cable. I bought my last one from someone on ebay.
     
    Great_Lakes likes this.
  20. Great_Lakes

    Joined:
    Apr 22, 2016
    Messages:
    269
    Likes Received:
    70
    Location:
    South Eastern Michigan
    I have to agree with you now. I bought directly from the DJI store this time primarily to prove or disprove that the ribbon cable is whats causing the problem. If it still doesn't fix it with the OEM cable from DJI, then at least I know I need to look for some other problem.

    Thanks for everyone's input. I'll get the new ribbon in 3 - 5 days and let you know.