Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Gimbal Control. X1 - F2 ?

Discussion in 'General Discussion' started by frankieplus, Sep 19, 2013.

  1. frankieplus

    Joined:
    Jul 28, 2013
    Messages:
    29
    Likes Received:
    0
    HI everyone..

    I'm trying to control the tilt / pitch on a Beholder Lite gimbal.

    I'm using the X1 port of the DJI Phantom controller and my pitch cable is plugged into F2 of the Naza.. Using the top pin for GND and the bottom pin for PITCH.

    Does this sound right? - Can't seem to get the gimbal tilt to work and I'm just troubleshooting.
     
  2. rilot

    Joined:
    Aug 18, 2013
    Messages:
    842
    Likes Received:
    5
    Location:
    Twyford, UK
    Have you turned on gimbal control in Naza Assistant? It's disabled by default I think.

    It's X1 and F1 by the way.
     
  3. marcus_canada

    Joined:
    Jul 22, 2013
    Messages:
    304
    Likes Received:
    4
    I think it IS F2 actually. The connections sound right to me, as said above, check the assistant is configured to allow gimbal control. Also be careful not to use full channel throw, limit the end points in the transmitter, not the assistant.
     
  4. rilot

    Joined:
    Aug 18, 2013
    Messages:
    842
    Likes Received:
    5
    Location:
    Twyford, UK
    You're probably right. I can't remember exactly.
     
  5. Dale Young

    Joined:
    Jul 31, 2013
    Messages:
    35
    Likes Received:
    0
    Rilot,
    I just installed a Beholder lite and noticed that when I connected the " Pitch" prong on the main board to the NAZA (F2 bottom prong) as you did, I got nothing. So I connected the 'Roll" prong of the main board to the NAZ (F2 bottom prong) and it worked.
    I havent added a potentiometer pot yet.

    I am wondering if my main board was labelled wrong.
     
  6. rilot

    Joined:
    Aug 18, 2013
    Messages:
    842
    Likes Received:
    5
    Location:
    Twyford, UK
    It's possible. The Chinese Martinez boards sometimes have custom firmware on them that has things on the wrong inputs. My first one wouldn't change pitch with the stock cable that came with it and I had to solder it to a different place on the board.
     
  7. frankieplus

    Joined:
    Jul 28, 2013
    Messages:
    29
    Likes Received:
    0
    Dale. I have the same problem. I am using X1 on the stock controller and F2 on the Naza. Top prong GND and bottom prong Pitch. Connected to the gimbal it does NOTHING.

    Did you connect it as above except connect to ROLL on the gimbal and it worked??


    -Frank
     
  8. frankieplus

    Joined:
    Jul 28, 2013
    Messages:
    29
    Likes Received:
    0
    Also Dale I got this from another forum

    In reference to the Gimbal GUI..

    "You just need to switch RC channel settings between roll and pitch tabs. There is a problem with pitch pin in the board, so the idea is to use roll pin instead of pitch. Switching RC channels in GUI will make you roll pin as pitch"
    ***************
     
  9. carpediem660

    Joined:
    Sep 30, 2013
    Messages:
    1
    Likes Received:
    0
    I am confused. When I received my beholder, it came with a black/red cable with two pigtails with conectors on them. One only had one wire and the other had three wires.

    I made a cable with a pitch and gnd that fit my board and attached it to F2. Did not work. (I enabled RC X1 and all that stuff) By sticking a small screwdriver into the back of the controller I moved the pot and it showed on the NAZAM asistant.

    Are you saying that I need to make a cable with ROLL and gnd to go to the board and still plug it in F2 the same as before.

    I have tried to get a response from beholder support with no luck.

    Thanks