Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Gimbal cannot receive MC data

Discussion in 'Pro/Adv Discussion' started by sammyhilfiger, May 31, 2015.

  1. sammyhilfiger

    Joined:
    May 20, 2015
    Messages:
    5
    Likes Received:
    1
    So, I've got my P3P few days ago.
    Updated firmware on both bird and RC right after opening from the box. (RC didn't need any update though)
    Took it outside 3 times and each time after I start the unit, I get this error message.
    Then I try to plug the black cable back in by pressing the end. Although it looked like it was connected all the way in. Message disappears and I proceed to calibrate compass and start the motor and get this bird up in the sky and shoot some videos with no problem.
    Did this happen because I have never done IMU calibration after the firmware update?
    Contacted DJI Live Chat and the agent told me that this is a probably defective unit and advised me to contact them via email. Just sent an email and I'm wondering if anyone else has same issue.
     

    Attached Files:

  2. DrChris

    Joined:
    Apr 18, 2015
    Messages:
    149
    Likes Received:
    76
    Location:
    Memphis, TN
    Has the error gone away for good after you re-seated the pins? If it persists after you have worked on that plug / pins, it may be a hardware issue that you need to have repaired.

    Chris
     
  3. sammyhilfiger

    Joined:
    May 20, 2015
    Messages:
    5
    Likes Received:
    1
    I didn't have to reseat the pins as they were properly installed. I just pushed it in like it would go in a bit more which it didn't. Error came back on when i turned off, went to different spot and turned back on.