Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Advanced gimbal & camera no power

Discussion in 'Phantom 3 Help' started by waghorn, Mar 27, 2016.

  1. waghorn

    Joined:
    Mar 27, 2016
    Messages:
    5
    Likes Received:
    0
    After a slight crash,,,,,,,,,, the Gimbal & Camera are not even powering up , I'm new at this please help .
     
  2. mdowney58

    Joined:
    Feb 15, 2016
    Messages:
    489
    Likes Received:
    113
    Location:
    Mountain City, TN
    Inspect the entire exterior portion of the flex (ribbon) cable first. It may have some damage.

    Sent from my SM-N910V using Tapatalk
     
  3. waghorn

    Joined:
    Mar 27, 2016
    Messages:
    5
    Likes Received:
    0
    thanks will try ,
     
  4. waghorn

    Joined:
    Mar 27, 2016
    Messages:
    5
    Likes Received:
    0
    nothing
     
  5. mdowney58

    Joined:
    Feb 15, 2016
    Messages:
    489
    Likes Received:
    113
    Location:
    Mountain City, TN
    I don't know the proper names for all the parts, but next, did you check the multi-line cable(s) that exits from the belly of the Phantom and plugs into the top of the gimbal to make sure they aren't dislodged?
    Providing that cable is fine, and if you are certain that there's absolutely zero damage to the exterior part of the flex cable, my next move would be to go into the upper portion and take it apart to inspect the rest of that flex cable. On my Standard, there's one connector on the end of it that plugs into the gimbal board, but on yours there may be two connections up there.
    Warning!!! It's not rocket surgery, but you should have the ability to take small things apart.

    Sent from my SM-N910V using Tapatalk
     
    #5 mdowney58, Mar 27, 2016
    Last edited: Mar 27, 2016
    waghorn likes this.