Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Gimbal being weird after first crash

Discussion in 'Phantom 2 Vision + Discussion' started by himo, Aug 2, 2014.

  1. himo

    Joined:
    Jul 15, 2014
    Messages:
    80
    Likes Received:
    2
    I just had my first crash today. I didnt even think it was that bad but my gimbal is acting strange. i can still get video but it vibrates, shakes and cant stabilize in place.

    attached a video below. any ideas??? there are no bent parts at all and my phantom is perfectly fine.


    https://www.youtube.com/watch?v=yD9VbyM ... load_owner
     
  2. himo

    Joined:
    Jul 15, 2014
    Messages:
    80
    Likes Received:
    2
    Any thoughts?
     
  3. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    9
    Location:
    Glen Burnie, MD - USA
    My guess is the camera slipped and has become misaligned on the pitch axis pin. There is a thread in here called something like Gimbal error RESOLVED. Find that thread and see if it can resolve your situation.
     
  4. himo

    Joined:
    Jul 15, 2014
    Messages:
    80
    Likes Received:
    2
    ok i will check for that thread. Do you think i have to replace the whole Gimbal? i am still getting video through it and it moves up and down but clicks sideways for some reason.
     
  5. kjopc

    Joined:
    May 18, 2014
    Messages:
    121
    Likes Received:
    30
    Location:
    Nipissing Township, Ontario, Canada
    It's so sad that these things aren't sufficiently robust to handle a bump. DJI can do better than that.
     
  6. himo

    Joined:
    Jul 15, 2014
    Messages:
    80
    Likes Received:
    2
    i know like my phantom looks perfectly fine which is weird. i have no idea where to start with this issue.
     
  7. DrTelemark

    Joined:
    Jul 27, 2014
    Messages:
    66
    Likes Received:
    0
  8. z10m

    Joined:
    Jul 18, 2014
    Messages:
    140
    Likes Received:
    1
    Location:
    Tunbridge Wells, England
    Welcome to the club....
    I'm thinking of ditching this crappy camera and gimbal and getting zenmuse, gopro and some 2.4Ghz FPV setup..
     
  9. himo

    Joined:
    Jul 15, 2014
    Messages:
    80
    Likes Received:
    2
    Are there any gimbals you guys recommend getting instead of the stock one? I think my problem is the same as the one in this thread : viewtopic.php?f=27&t=20514&start=70. I unscrewed the back and aligned the pin and the camera. my pin seems to be loose and easy to turn. I did not apply jb weld on the back yet but i tried testing and it behaved better and then went back to being crazy.
     
  10. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    9
    Location:
    Glen Burnie, MD - USA
    You mentioned it being a lose fit on the shaft, so it probably slipped again. You should realign it again, apply just a dot of JB weld or loctite, then test it on the table. If it is correctly aligned and behaving normally, then apply enough JB weld of loctite to keep it securely in place.
     
  11. himo

    Joined:
    Jul 15, 2014
    Messages:
    80
    Likes Received:
    2
    dirty bird youre all over this forum lol good job !!!.....i fixed it with loctite. Its working better than before. im just waiting for it to cure for 24 hours. i did a very light test seems to be running perfect and quiet. I think i lucked out coz it seems perfectly aligned to me !! thanks a lot man saved me couple of hundreds
     
  12. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    9
    Location:
    Glen Burnie, MD - USA
    Cool beans! ;)