Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Getting a lot of signal loss

Discussion in 'Phantom 2 Vision Discussion' started by ccase39, Jan 27, 2015.

  1. ccase39

    Joined:
    Jan 3, 2015
    Messages:
    471
    Likes Received:
    17
    I was flying in ground station today and several times it said connection lost, signal lost, "could not connect to ground station. Retry?" Each time it did continue on its mission and come home and I would eventually regain signal. At one point when it got home it just hovered for about 30 seconds and would not let me regain control. I thought I saw the LEDS flash yellow at this point but can not be 100% sure.


    Signal loss has happened to me in just regular flight as well. I keep the point of antenna and wifi extender pointed towards my Phantom. I am not using the latest version of the app. I had installed it but was having problems with the camera crashing so I reinstalled the one before the latest one.
     
  2. general01

    Joined:
    Feb 27, 2014
    Messages:
    468
    Likes Received:
    4
    The point of the antenna is where the signal is the weakest on the transmitter

    The repeator could be bad or weak
    Also interference can cause signal issues if it's on the same band(2.4 ghz) or if the device sees another wifi signal
    The tail leds will flash yellow if the phantom detects a lose of transmittor signal
     
  3. Great Pumpkin

    Joined:
    Feb 23, 2014
    Messages:
    405
    Likes Received:
    35
    Location:
    Santa Barbara County, California, USA
    Wrong. The length of the antenna should be almost perpendicular to the Phantom. Just have it standing vertical, but yes, aim the wifi extender at the Phantom.
     
  4. mad in nc

    Joined:
    Dec 16, 2014
    Messages:
    534
    Likes Received:
    214
    Location:
    North Carolina US

    When you loaded the new app that crashed like all of us... did you also update the WiFi extender available in the new app before going back to the old app?
     
  5. ccase39

    Joined:
    Jan 3, 2015
    Messages:
    471
    Likes Received:
    17
    no I didn't update anything. I will check out the antenna angle next time. I bet that's the problem. At least it did what it was supposed to do and came home. Im a little more confident now.