Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Galaxy G5 android doesn't seem to work with DJI GS

Discussion in 'DJI Ground Station' started by DrD, Aug 24, 2014.

  1. DrD

    DrD

    Joined:
    Aug 19, 2014
    Messages:
    107
    Likes Received:
    0
    With my new p2v+, in phantom mode, I have not been able to get GS working. I constantly get "Phantom Connection Broken" pop up screens, which will not let me center maps on my area of interest, and so I cannot proceed any further with waypoint setting, etc.

    I'm using a Galaxy G5, with the DJI Vision app. I am able to connect with the Phantom p2v+, have all the latest updates, I have 6 or more GPS satellites displayed, and I can switch to the GS screen and a map is present ... but anything I do after moving the map around (with finger gestures) invokes a broken connection message.

    Can anyone confirm success with the setup I've described, or does the GS app not work with this equipment?

    Thanks,

    -Dale-
     
  2. BWJ

    BWJ

    Joined:
    Aug 19, 2014
    Messages:
    144
    Likes Received:
    0
    Location:
    Denmark
    You have to disable mobile data on the phone, then it works.
     
  3. DrD

    DrD

    Joined:
    Aug 19, 2014
    Messages:
    107
    Likes Received:
    0
    Thank you very much. I just tried that, unchecked "Mobile Data," and GS now seems to be working. I never would have thought to try that, so you have been a great help. I hope to return the favor someday!

    -Dale-
     
  4. DrD

    DrD

    Joined:
    Aug 19, 2014
    Messages:
    107
    Likes Received:
    0
    Re: Galaxy G5 android doesn't seem to work with DJI GS (Upda

    The recommendation to turn off mobile data helped. I can get to maps, and all is well UNTIL I zoom in to a level where I could actually insert waypoints. At that level, a "Phantom Connection Broken" message pops up and breaks an existing working connection with the Phantom. At the zoomed out level, all is well.

    Is there more that I can do within the galaxy g5 settings to make this work? I have Mobile Data unchecked, wifi on, locations off, I get maps ok, but can't zoom into them very close. Each time the pop up broken connection message occurs, my maps get reset, and zooming into them just enters a repeat loop.

    Thanks if you can help!

    -Dale-
     
  5. BWJ

    BWJ

    Joined:
    Aug 19, 2014
    Messages:
    144
    Likes Received:
    0
    Location:
    Denmark
    Im sure its because it try to update the scaled map via wifi (your home wifi).
    Try to zoom to wanted level so the map is cached in memory, before connect to PH.

    Sorry for my english - im an danish viking :)
     
  6. DrD

    DrD

    Joined:
    Aug 19, 2014
    Messages:
    107
    Likes Received:
    0
    I *think* I've found a way to make it work!: (Galaxy S5 -> DJI Vision Ground Station -> Phantom 2v+)

    1. Enable Wifi. (S5)
    2. Enable Location. (S5)
    3. Activate RC -> Wifi Extender -> Phantom
    3. Run DJI Vision Ap -> left swipe to Ground Station. (S5)
    4. Adjust map (If Necessary). (S5 -> GS)
    5. Disable Location. (S5)
    6. Lock North (makes it easy to insert waypoints). (S5 -> GS)
    7. Append waypoints / adjust map (within limits of cached map, otherwise it breaks the connection!) (S5 -> GS)
    8. Adjust waypoints for precise location and altitude. (S5 -> GS)
    9. Click 'Done' (S5 -> GS)
    10 Click 'Go' (if no flight restrictions, path fully validated for obstructions, and you're brave enough!) (S5 -> GS)

    I have (finally) made this sequence work for three different missions, but haven't been brave enough to fly them yet! (Tomorrow morning...)

    Thank you for the help thus far. Feel free to amend this list, if you know of a better way to do this ,with this temperamental set up. Mobile Data checked or unchecked made no difference with this sequence.

    -Dale-