Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

FW 1.5 rollback to before 500m limit?

Discussion in 'Pro/Adv Discussion' started by Cynical, Jan 25, 2016.

  1. Cynical

    Joined:
    Jan 11, 2016
    Messages:
    46
    Likes Received:
    6
    Hi guys.
    I thought i had 1.6 installed but its 1.5 on my P3P.
    Anyway to roll back to when the 500m limit wansnt there on DJ GO or Litchi?


    Sent from my iPhone using PhantomPilots mobile app
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,914
    Likes Received:
    5,570
    Location:
    US
  3. Cynical

    Joined:
    Jan 11, 2016
    Messages:
    46
    Likes Received:
    6
    That was bad news. Short bad news :)
    Then i dont need to be afraid Of 1.6 then since the geo stuff wont affect me at all.
     
  4. Shaiful Rizhuan

    Joined:
    Jan 12, 2016
    Messages:
    104
    Likes Received:
    27
    I think if you're on 1.5, you can downgrade to 1.4 which is the last firmware without 500m limit. Nothing you can do if you're on 1.6
     
    Cynical likes this.
  5. Cynical

    Joined:
    Jan 11, 2016
    Messages:
    46
    Likes Received:
    6
    Oh!
    What firmwares and softwares do i need them?
    Where i live in Sweden. All these restrictions is just stupid for me
     
  6. jryser

    Joined:
    Aug 3, 2014
    Messages:
    328
    Likes Received:
    118
    Location:
    Indiana
    I'm not sure there was ever anything at least in the Go app that allowed over 500 m.


    Sent from my PT beating heart
     
  7. Cynical

    Joined:
    Jan 11, 2016
    Messages:
    46
    Likes Received:
    6
    Ok trying to find instructions for rollback on the drone and controller. Hope it can work. Bought it for those high altitude shots before i knew of the new restrictions


    Sent from my iPhone using PhantomPilots mobile app
     
  8. Shaiful Rizhuan

    Joined:
    Jan 12, 2016
    Messages:
    104
    Likes Received:
    27
    Firmware 1.4 + Older version of Litchi. It will take you at least hours to find it in the internet though. I did found one before. No go for me because I can't downgrade my firmware from 1.6. Go search for it. I don't think it's appropriate to discuss about pirated apps here.
     
  9. Cynical

    Joined:
    Jan 11, 2016
    Messages:
    46
    Likes Received:
    6
    Ok does it matter what firmware the controller has?
     
  10. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    There always was a 500 meter height limit.
     
  11. Cynical

    Joined:
    Jan 11, 2016
    Messages:
    46
    Likes Received:
    6
    Ok but not in Litchi?
     
  12. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    I dont know, always there in go.
     
    Cynical likes this.
  13. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,914
    Likes Received:
    5,570
    Location:
    US
    True. However, there was a way to get around it. DJI patched it though.
     
  14. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    Ok, right, thanks