Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Futaba 8FG Self Centering

Discussion in 'Phantom 2 Help' started by vongjs, Mar 24, 2014.

  1. vongjs

    Joined:
    Mar 24, 2014
    Messages:
    1
    Likes Received:
    0
    Hello all!

    I need assistant with Futaba 8FG I'm a rookie come to RC stuff any help would be greatly appreciated. Here is what I need help with. I owned Futaba 8FG and I have made it self center like DJI controller. How would I go about making 8FG controller not to power up the motor to 50% when I arm the motor when the throttle stick at center. On DJI controller when you arm the motor and let go the throttle and it self center the motor stay at idle, but not on Futaba. What setting do I need to modify to make the 8FG act like DJI controller. Is it possible or do I need to for go Futaba and just buy the DJI controller with receiver. Again any help would greatly appreciated.
     
  2. RogerClark

    Joined:
    Feb 12, 2014
    Messages:
    147
    Likes Received:
    0
    I'm not sure what you mean

    I have an 8FG without centering, but if I move the throttle to the center after starting the motors, it stays in idle

    Have you calibrated the center point of your throttle correctly?

    Or have you tried letting it go back to the center a bit slower after doing the command start thingy?
     
  3. RickF

    Joined:
    Mar 2, 2014
    Messages:
    70
    Likes Received:
    0
    Location:
    Illinois
    I think I know what you mean. I have a Futaba 14 SG that came with the new Phantom 2 (non-vision) that I just bought, adding to the Phantom 2 Vision I had already purchased. I’m new to flying things so I was immediately and completely spoiled with the simple remote control unit (radio) that comes with the Phantom 2 Vision. Just let go of the sticks on the P2V and the Phantom stays where it is. But the up/down, rotation stick, the left stick, on the 14 SG does not spring back to the center position when you let go. I am very concerned about lowering the stick too far and having my Phantom stall and crash. I was wondering if there was a way to calibrate the left stick so that the very bottom position does not result in shutting things down. If you can’t do that I was wondering if I could at least increase the time the stick has to be in the full down position before it shuts the motors down. Something along the line of 10 seconds or so instead of the 2-3 seconds in its current configuration.
     
  4. DesertFlyer53

    Joined:
    Feb 21, 2014
    Messages:
    630
    Likes Received:
    1
    Location:
    Ridgecrest, CA
  5. Hiway

    Joined:
    Nov 28, 2013
    Messages:
    491
    Likes Received:
    2
    ...except for his last question, which is something I am trying to figure out as well... I do not like how abruptly the motors shut off when the throttle stick hits bottom- while I have the centering spring (free from Futaba) and had no issue installing it (just refer to the way the right stick is centered when you open the radio- it makes sense) I do not have a clue how to resolve what this post asks:

     
  6. DesertFlyer53

    Joined:
    Feb 21, 2014
    Messages:
    630
    Likes Received:
    1
    Location:
    Ridgecrest, CA
    I used that function to shut down my motors after landing. Just hold the left stick down until they shut off. For me it's a handy feature and I don't have a problem with it. It's not a good idea to desend so fast that you hit this area of the stick in flight anyway, because of the rotor wash issue resulting in crashes from fast desents that is well documented here.
     
  7. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    The amount of time can't be changed because that's coded in the NAZA. What you probably need to do is just adjust your throttle curve so it never goes below 10% (that's the point the NAZA considers your sticks to be "all the way down" for the purpose of killing the engines)
     
  8. Hiway

    Joined:
    Nov 28, 2013
    Messages:
    491
    Likes Received:
    2
    Understood- but I wanted a delay... as did Rick. I don't mind it shutting down- that is pretty much par for the course in flying r/c from my understanding... but a brief delay would be nice- like 2 seconds.
     
  9. Hiway

    Joined:
    Nov 28, 2013
    Messages:
    491
    Likes Received:
    2

    There it is... I have NOT tried that.
     
  10. DesertFlyer53

    Joined:
    Feb 21, 2014
    Messages:
    630
    Likes Received:
    1
    Location:
    Ridgecrest, CA
    The 2 to 3 second delay is already there from my experience. My motors don't shut down instantaniously.
     
  11. Hiway

    Joined:
    Nov 28, 2013
    Messages:
    491
    Likes Received:
    2
    Ah... mine are instant.
     
  12. RogerClark

    Joined:
    Feb 12, 2014
    Messages:
    147
    Likes Received:
    0
    Just a thought, but you could assign one of the switches to the Throttle Curve, and set it, so that the power on the motors won't go below some predefined value e.g. 10% unless the switch is OFF.

    I've noticed using Ian Woods config profile, that the Phantom won't start unless the rate control switch is in its off position, as it limits the rudder and elevator (and possibly the ailerons)

    So this would be the same thing, but for throttle and on a different switch

    BTW. I've seen a video on YouTube to do an "auto hover" using a switch to set he throttle curve to 50% regardless of throttle position. I had considered making the change, as I've not got a centering spring kit yet.
     
  13. bernardb

    Joined:
    Jan 19, 2014
    Messages:
    122
    Likes Received:
    0
    Location:
    Avon Indiana
    In the Assistant there is a setting for motor shut off - 2 choices I think:

    1. Immediately
    2. Intelligent

    Have a look at those....
     
  14. Hiway

    Joined:
    Nov 28, 2013
    Messages:
    491
    Likes Received:
    2
    Yes- and it is set to Intelligent.
     
  15. Quadro

    Joined:
    Feb 5, 2014
    Messages:
    34
    Likes Received:
    0
    I have the 8FG. I also removed the throttle rachet and added the self centering kit. I suggest you go to the thread mentioned by several people already:

    http://phantompilots.com/viewtopic.php?f=19&t=8358

    and download Ian Wood's P2 Profile (now in V4, I believe) and follow the directions on how to copy it to your 8FG, it will solve all your problems -- plus provide you with some nifty extras like a timer that starts when you engage the throttle (so you can't forget it), dual-speed modes, and several gimbal control options.

    Just be sure you understand what all the switch and knobs do -- especially the Failsafe switch and why you MUST keep the gimbal knob in its off position.

    Good luck.