Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

FPVLR problem

Discussion in 'Pro/Adv Discussion' started by Fares, Jul 16, 2015.

  1. Fares

    Joined:
    Jun 9, 2015
    Messages:
    134
    Likes Received:
    13
    Hey guys
    I have installed the FPVLR advanced kit and I follow step by step they instructions. The problem is when i turn on my controller it doesn't stop beeping plus error message say high interface.

    Anyone have a solution for this?
     
  2. Jacob

    Jacob Administrator
    Staff Member

    Joined:
    Mar 3, 2015
    Messages:
    737
    Likes Received:
    305
  3. BenDronePilot

    Joined:
    Dec 7, 2013
    Messages:
    1,204
    Likes Received:
    131
    Sounds like you either did not put something back together snugly, or something became damages. Immediately power down. Take the controller apart and re-do the connections. Of course I assume when you turned on the controller you had the antennas plugged in at the time. Do NOT power on the controller without antennas or you'll fry it.
     
  4. Fares

    Joined:
    Jun 9, 2015
    Messages:
    134
    Likes Received:
    13
    Controller working. Everything is working plus boosters. I also receive live FPV on my iPhone. Only problem is poor signal controller beeping loudly !!!
     
  5. Fares

    Joined:
    Jun 9, 2015
    Messages:
    134
    Likes Received:
    13
    Does it matter which cable is going where? I just pluged the antenna like this.
    Here is my setup:
    ImageUploadedByPhantomPilots1437055533.541003.jpg ImageUploadedByPhantomPilots1437055548.156641.jpg ImageUploadedByPhantomPilots1437055558.291181.jpg ImageUploadedByPhantomPilots1437055567.124950.jpg
     
  6. Morphious

    Joined:
    Jun 19, 2015
    Messages:
    205
    Likes Received:
    83
    Did you connect the output/USB board correctly (all three ribbon cables)?
    You should have followed directions and run cables under board, you are interfering with sticks and who knows what else. When I do mine, I will put a drop of hot glue on the RF connectors.
     
    AmosMoses likes this.
  7. Fares

    Joined:
    Jun 9, 2015
    Messages:
    134
    Likes Received:
    13
    Okay guys, here is what i found out
    You have to snap the correct antenna cable in the right place. They dont mark it. So you have to try your luck and if you face same as my problem. Open up the controller and switch cables.
    Here is my final setup. ImageUploadedByPhantomPilots1437061113.748341.jpg ImageUploadedByPhantomPilots1437061124.335471.jpg ImageUploadedByPhantomPilots1437061134.323686.jpg
    After this I powered up everything and no errors coming up.
    Field test tomorrow morning. Good luck pilots.
     
  8. rrmccabe

    Joined:
    Jul 2, 2014
    Messages:
    1,647
    Likes Received:
    358
    Location:
    Ankeny, Iowa
    Not exactly sure what you are saying but it does not matter what FPVLR cable is connected where. They are the same antennas and can be connected either way.
     
    BenDronePilot likes this.
  9. Fares

    Joined:
    Jun 9, 2015
    Messages:
    134
    Likes Received:
    13
    Nope. When you install yours you might face same problem. Just cameback here and you will get what i mean.
     
  10. rrmccabe

    Joined:
    Jul 2, 2014
    Messages:
    1,647
    Likes Received:
    358
    Location:
    Ankeny, Iowa
    If you are talking about the actual coax cables from the FVPLR antennas it doesn't matter. They are both the same half dome CP antenna.

    I have no doubt it started working for you but during all this monkeying around you must have seated a connection or something. Tony is on vacation but when he returns I am sure he will agree it doesn't matter. If it did he would have specified that.

    Regardless, enjoy your new antennas. You should have some really good range now.
     
    phantom13flyer likes this.